Bug 179

Summary: razor check skipped: No such file or directory undefined Razor::Client
Product: Spamassassin Reporter: Gerard Beekmans <gerard>
Component: spamassassinAssignee: SpamAssassin Developer Mailing List <dev>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: P2    
Version: 2.11   
Target Milestone: ---   
Hardware: Other   
OS: Linux   
Whiteboard:

Description Gerard Beekmans 2002-04-04 09:32:24 UTC
Seems I'm not too lucky here with the Razor integration.

It was all working nicely when called from a procmail setup, but I want to tie
it in with Postfix. When the filter script runs from within postfix (i'll attach
the script I'm using), I get the error as quoted in the Summary field above.
What file or directory is it complaining about? When this script finishes
running spamassassin, I have it run razor-check as well, and razor-check has no
problems finding whatever file/directory spamassassin is having problems with.
Here's some output:

debug: using "/usr/local/share/spamassassin" for default rules dir
debug: using "/etc/mail/spamassassin" for site rules dir
debug: using "/var/spool/postfixfilter/.spamassassin" for user state dir
debug: using "/var/spool/postfixfilter/.spamassassin/user_prefs" for user prefs file
debug: running header regexp tests; score so far=0
debug: running body-text per-line regexp tests; score so far=4
debug: running raw-body-text per-line regexp tests; score so far=13.3
debug: running full-text regexp tests; score so far=18.8
debug: Razor is available
razor check skipped: No such file or directory undefined Razor::Client
debug: Razor Agents 1.20, protocol version 2.
debug: Read server list from /.razor.lst
debug: 15543 seconds before closest server discovery
debug: Agent terminated


And the razor-check output from that same script:

debug: Razor Agents 1.20, protocol version 2.
debug: Read server list from /.razor.lst
debug: 10492 seconds before closest server discovery
debug: Closest server is 64.90.187.2
debug: Connecting to 64.90.187.2...
debug: Connection established
debug: Signature: 7078083d5dcfb6f70ef750d013da710056e86066
debug: Server version: 1.11, protocol version 2
debug: Server response: Positive 7078083d5dcfb6f70ef750d013da710056e86066
debug: - Message 1 is KNOWN SPAM -
debug: Agent terminated

Now, I rerun the same spamassassin command manually on the same file as the
script would run it on when called from within postifx, and it does the Razor
check fine.

So, I'm looking most likely at a possible permission problem? Is there a way to
turn up the notch on diagnostics output so it'll tell me which file/directory
it's having problems with?
Comment 1 Duncan Findlay 2002-04-04 19:14:03 UTC
This is a known issue. It's in the FAQ on the website.

*** This bug has been marked as a duplicate of 79 ***
Comment 2 Gerard Beekmans 2002-04-04 19:18:11 UTC
Yes, 1.20

I read the FAQ entry but I didn't think it applied (especially after that other
fix that was posted yesterday fixed the problems) since Spamassassin works just
fine when _not_ running as a Postfix content_filter. It only fails when postfix
invokes it, so I'm guessing this is more of a Postfix problem than Spamassassin.
If I find the reason for it I'll post a follow-up (in bug #79 then).