Bug 1650 - RFE: would be nice to be able to update the bayes db from spamd
Summary: RFE: would be nice to be able to update the bayes db from spamd
Status: RESOLVED DUPLICATE of bug 1201
Alias: None
Product: Spamassassin
Classification: Unclassified
Component: spamc/spamd (show other bugs)
Version: 2.50
Hardware: PC Linux
: P5 enhancement
Target Milestone: 3.0.0
Assignee: SpamAssassin Developer Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-03-16 05:14 UTC by James Henstridge
Modified: 2004-03-05 04:46 UTC (History)
0 users



Attachment Type Modified Status Actions Submitter/CLA Status

Note You need to log in before you can comment on or make changes to this bug.
Description James Henstridge 2003-03-16 05:14:24 UTC
It would be nice to be able to update the bayes database of a user via spamd.

I run spamd under an unprivileged account, with the virtual user dir option so
that separate whitelists and bayes dbs are maintained for each user.  All
interaction with SA goes through spamd.  (This setup is mainly to support the
Windows users on the network).

If spamd provided commands to update the bayes db, it would be easier for me to
provide an interface for users to update the bayes db.

Another place where it would be useful is for Mailman integration.  Currently I
use spamd to check messages as they get posted and hold or discard spam, but it
would be nice to be able to use the results of list moderation to update the
bayes db for the list.

Probably adding a pair of commands like "BAYES_SPAM" and "BAYES_HAM" would do
the trick.
Comment 1 James Henstridge 2003-03-24 01:19:20 UTC
Maybe a better API would be:
  LEARN SPAMD/x.y
  Status: (spam|ham|forget)
  Rebuild: (yes|no)

  <message goes here>

Both headers would be optional, with the first arg defaulting to spam, and the
second to yes.

An additional "REBUILD" method could be added to do a rebuild without learning a
new message.
Comment 2 Michael Parker 2004-03-05 13:46:51 UTC

*** This bug has been marked as a duplicate of 1201 ***