Bug 2001 - req: run DNSBL tests on hostnames found in body uris
Summary: req: run DNSBL tests on hostnames found in body uris
Status: RESOLVED DUPLICATE of bug 1375
Alias: None
Product: Spamassassin
Classification: Unclassified
Component: Rules (Eval Tests) (show other bugs)
Version: 2.55
Hardware: Other Linux
: P5 enhancement
Target Milestone: 2.70
Assignee: SpamAssassin Developer Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-05-31 11:32 UTC by Mark Shaw
Modified: 2003-06-20 04:51 UTC (History)
0 users



Attachment Type Modified Status Actions Submitter/CLA Status

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Shaw 2003-05-31 11:32:38 UTC
Many spammer's web sites are alread listed by SBL or other DNSBLs,
while the spam source is a random abused proxy. Is it possible to add
DNSBL tests based on IP addresses of hosts in the message body, both
those mentioned in URLs and possibly those that are MX for domains
in e-mail addresses (remove, sales, etc)?
Comment 1 Daniel Quinlan 2003-06-20 12:51:39 UTC
There's an existing bug for URL tests.

2.60-cvs already tests From: address domains.

I tried testing mailto: in addition to the From: addresses and the results
are iffy:

before:  4.406  10.7944   0.0622    0.994   0.93    1.00  DNS_FROM_RFCI_DSN
after:   7.200  14.2000   0.2000    0.986   0.90    1.00  DNS_FROM_RFCI_DSN

the delta: 3.40% SPAM, 0.1378% HAM = S/O ratio of 0.96

Could be better, so we'll just stick with the current DSN test for now.


*** This bug has been marked as a duplicate of 1375 ***