Bug 2206 - possible undefined variable in harvest_dnsbl_queries()
Summary: possible undefined variable in harvest_dnsbl_queries()
Status: RESOLVED FIXED
Alias: None
Product: Spamassassin
Classification: Unclassified
Component: Libraries (show other bugs)
Version: 2.60
Hardware: PC Linux
: P3 critical
Target Milestone: 2.60
Assignee: Daniel Quinlan
URL:
Whiteboard:
Keywords:
: 2339 2343 2355 2361 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-07-10 11:21 UTC by Malte S. Stretz
Modified: 2003-08-25 15:07 UTC (History)
5 users (show)



Attachment Type Modified Status Actions Submitter/CLA Status
fix undefined variable error patch None Daniel Quinlan [HasCLA]

Note You need to log in before you can comment on or make changes to this bug.
Description Malte S. Stretz 2003-07-10 11:21:39 UTC
My mass-check for 2.60 gave the following output: 
| mss@otherland:~/tmp/Mail-SpamAssassin-2.60/masses> ./mass-check --net -j 4 
|--all -f /home/mss/projects/spamassassin/corpus/index --progress 
| status: pre-scanning and sorting. now: 2003-07-10 00:17:03 
| status:  10% ham: 1078   spam: 1076   date: 2002-07-18  
|now: 2003-07-10 02:11:55 
| Can't use an undefined value as an ARRAY reference at 
|/var/homes/mss/tmp/Mail-SpamAssassin-2.60/masses/../lib/Mail/SpamAssassin/Dns.pm 
|line 30 
| Got an undef from readline?!?  Restarting all children, probably lost some 
|results. :( 
| status:  20% ham: 2322   spam: 1986   date: 2003-01-13  
|now: 2003-07-10 03:53:48 
| status:  30% ham: 4476   spam: 1986   date: 2003-02-05  
|now: 2003-07-10 05:27:54 
| status:  40% ham: 6630   spam: 1986   date: 2003-02-26  
|now: 2003-07-10 07:00:55 
| status:  50% ham: 8784   spam: 1986   date: 2003-03-15  
|now: 2003-07-10 08:36:17 
| status:  60% ham: 10938  spam: 1986   date: 2003-04-01  
|now: 2003-07-10 10:14:02 
| status:  70% ham: 13092  spam: 1986   date: 2003-04-20  
|now: 2003-07-10 11:52:01 
| status:  80% ham: 15246  spam: 1986   date: 2003-05-16  
|now: 2003-07-10 13:31:47 
| status:  90% ham: 17400  spam: 1986   date: 2003-06-11  
|now: 2003-07-10 15:14:53 
| status: 100% ham: 19554  spam: 1986   date: 2003-07-09  
|now: 2003-07-10 17:00:18 
 
Seems like $query->[RULES] was undef in that line in Dns.pm -- maybe because 
of a timeout or something.
Comment 1 Arkadiusz Miskiewicz 2003-08-21 14:51:32 UTC
Only /me too with 2.60 version. 2.55 was working fine. When running exiscan 
with spamassassin this message (about xxx ARRAY) goes over tcp/ip socket and 
exiscan repllies with: 
2003-08-21 23:46:44 19pxGU-00045E-52 spam acl condition: cannot parse spamd 
output 
and message is rejected. 
Comment 2 Daniel Quinlan 2003-08-21 21:31:23 UTC
This needs to be figured out, people have reported it in 2.60-rc1.
Comment 3 Daniel Quinlan 2003-08-21 21:33:08 UTC
changing to 2.60 milestone
Comment 4 Daniel Quinlan 2003-08-21 21:41:15 UTC
Created attachment 1251 [details]
fix undefined variable error

The error causes the SpamAssassin process to die if a DNS blacklist times
out.  This probably went almost unnoticed during mass-check due to lack of
many timeouts as well as having multiple processes around plus the --restart
flag.  I think this bug unfortunately needs to be fixed for 2.60.
Comment 5 Steve Halligan 2003-08-22 07:00:41 UTC
Quinlan's patch fixed it for me.
Comment 6 Chris Horry 2003-08-22 08:45:19 UTC
Still getting same error here after applying patch.
Comment 7 Chris Horry 2003-08-22 08:52:57 UTC
My bad, working OK after reloading my MTA.  Will report back if I get any more
issues.
Comment 8 Theo Van Dinter 2003-08-22 11:24:22 UTC
+1 this fixes the bug for me too
Comment 9 Justin Mason 2003-08-22 11:46:01 UTC
+1
Comment 10 Theo Van Dinter 2003-08-22 12:49:03 UTC
*** Bug 2343 has been marked as a duplicate of this bug. ***
Comment 11 Theo Van Dinter 2003-08-22 13:38:50 UTC
*** Bug 2339 has been marked as a duplicate of this bug. ***
Comment 12 Daniel Quinlan 2003-08-22 13:43:01 UTC
fixed in CVS HEAD
Comment 13 Theo Van Dinter 2003-08-25 07:09:58 UTC
*** Bug 2355 has been marked as a duplicate of this bug. ***
Comment 14 Theo Van Dinter 2003-08-25 22:13:18 UTC
*** Bug 2361 has been marked as a duplicate of this bug. ***