Bug 2390 - RPM built from RC3 CVS has bogus dependency
Summary: RPM built from RC3 CVS has bogus dependency
Status: RESOLVED FIXED
Alias: None
Product: Spamassassin
Classification: Unclassified
Component: Packaging: RPM (show other bugs)
Version: SVN Trunk (Latest Devel Version)
Hardware: PC Linux
: P5 major
Target Milestone: 2.60
Assignee: Theo Van Dinter
URL:
Whiteboard:
Keywords:
: 2392 2420 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-08-31 01:44 UTC by Dave Hill
Modified: 2003-09-08 08:30 UTC (History)
3 users (show)



Attachment Type Modified Status Actions Submitter/CLA Status
suggested patch patch None Theo Van Dinter [HasCLA]

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Hill 2003-08-31 01:44:26 UTC
I built the CVS version of 2003-08-30 as an RPM (as I usually do) on Redhat 9,
but it will not install, the message is:-

error: Failed dependencies:
        perl() >= . is needed by perl-Mail-SpamAssassin-2.60-20030830

I tracked this down (via /usr/lib/rpm/perl.req) to a line in BayesStore.pm
which reads:

      use ' . $dbm . ';

in the new "upgrade_old_dbm_files_trapped()" routine. This obviously confuses
perl.req.
Comment 1 Malte S. Stretz 2003-08-31 20:17:20 UTC
*** Bug 2392 has been marked as a duplicate of this bug. ***
Comment 2 Theo Van Dinter 2003-09-06 22:57:13 UTC
gotta love that rpm perl.req script. <sigh>
Comment 3 Theo Van Dinter 2003-09-06 23:00:24 UTC
Created attachment 1322 [details]
suggested patch

we had the same problem before when doing the blib stuff in the scripts.

/usr/lib/rpm/perl.req (or your local equivilent) looks for '^\s+(use|require)',
which doesn't pay attention to things like eval.

This patch simply moves the "use" up to the same line as the eval.
Comment 4 Daniel Quinlan 2003-09-06 23:02:43 UTC
+1 ick
Comment 5 Dave Hill 2003-09-07 00:33:55 UTC
Yes, that fixes it.

Dave
Comment 6 Justin Mason 2003-09-07 23:42:57 UTC
+1 -- hate stupid scripts trying to second-guess perl
Comment 7 Theo Van Dinter 2003-09-08 05:35:46 UTC
committed. :)
Comment 8 Theo Van Dinter 2003-09-08 16:30:44 UTC
*** Bug 2420 has been marked as a duplicate of this bug. ***