Bug 441 - eval:subject_is_all_caps() matches subjects with no capital letters
Summary: eval:subject_is_all_caps() matches subjects with no capital letters
Status: RESOLVED FIXED
Alias: None
Product: Spamassassin
Classification: Unclassified
Component: Libraries (show other bugs)
Version: SVN Trunk (Latest Devel Version)
Hardware: All All
: P2 normal
Target Milestone: ---
Assignee: Daniel Quinlan
URL:
Whiteboard:
Keywords:
: 445 452 (view as bug list)
Depends on:
Blocks:
 
Reported: 2002-06-13 14:08 UTC by Daniel Quinlan
Modified: 2002-06-14 14:48 UTC (History)
2 users (show)



Attachment Type Modified Status Actions Submitter/CLA Status
proposed patch patch None Daniel Quinlan [HasCLA]

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Quinlan 2002-06-13 14:08:32 UTC
This line:

   $subject =~ s/[^a-zA-Z]//;

is missing a trailing "g" to make the replacement global.
Comment 1 Daniel Quinlan 2002-06-13 17:01:39 UTC
Created attachment 177 [details]
proposed patch
Comment 2 Daniel Quinlan 2002-06-13 17:09:42 UTC
I'd like to apply the patch before 2.30 gets released, but I want someone
else to look it over before I apply it since we're in a freeze.  Of course,
I tested it, but I'm feeling a bit sheepish after check_for_mime_excessive_qp().

The patch fixes several bugs in subject_is_all_caps() and simplifies
the SUBJ_MISSING rule which was unnecessarily complicated.
Comment 3 Duncan Findlay 2002-06-13 22:31:34 UTC
looks good to me. Haven't actually tested it though :-)
Comment 4 Daniel Quinlan 2002-06-13 23:17:28 UTC
applied patch to tree
Comment 5 Daniel Quinlan 2002-06-14 11:19:46 UTC
*** Bug 445 has been marked as a duplicate of this bug. ***
Comment 6 Andrey Ulanov 2002-06-14 11:56:57 UTC
Of course subject line should be MIME-encoded if it includes cyrillic characters. But it isn't always in real life. Some brain-damaged mailers still use 8bit in subject line. So i think it will be better to use ([^\w]|\d|_) instead of [^a-zA-Z].
Comment 7 Duncan Findlay 2002-06-14 22:48:58 UTC
*** Bug 452 has been marked as a duplicate of this bug. ***