Bug 5310 - X-Spam-Report broken in Evolution
Summary: X-Spam-Report broken in Evolution
Status: RESOLVED INVALID
Alias: None
Product: Spamassassin
Classification: Unclassified
Component: spamassassin (show other bugs)
Version: 3.1.7
Hardware: PC Linux
: P5 minor
Target Milestone: Undefined
Assignee: SpamAssassin Developer Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-01-25 15:59 UTC by Raul Dias
Modified: 2019-09-25 03:04 UTC (History)
2 users (show)



Attachment Type Modified Status Actions Submitter/CLA Status
header_report_multiline option patch patch None Raul Dias [NoCLA]
Preserve headers in evolution-data-server patch None Craig Shelley [NoCLA]

Note You need to log in before you can comment on or make changes to this bug.
Description Raul Dias 2007-01-25 15:59:23 UTC
Evolution (in any version), when dealing with headers with multiple lines,
rearrange the lines.

This has a terrible problem with SpamAssassin as it makes difficult to analise
the rules triggered by ham/spam.

For example, the header:

X-Spam-Report: * 4.2 bla bla blabla blabla bla
      * -1.0 bla bla blabla blabla bla
      *  3.1 foo fo ofoo bla bar bar bar

will be changed to something like:

X-Spam-Report: * 4.2 bla bla blabla blabla bla * -1.0 
      bla bla blabla blabla bla *  3.1 foo fo ofoo bla 
      bar bar bar

To make things even worse, evolution is not completly wrong in doing this. This
is not common, but it is not forbidden in the RFCs.

So, to solve this problem I have updated a patch to insert a new option to SA:
header_report_multiline 

if set to 1 (defaults to 0), will insert each line of X-Spam-Report as a new
header, making it readable in clients such as evolution.
Comment 1 Raul Dias 2007-01-25 16:01:52 UTC
Created attachment 3843 [details]
header_report_multiline option patch

This is the patch that inserts the option header_report_multiline for "broken"
MUAs.
Comment 2 Craig Shelley 2007-10-28 01:55:20 UTC
Created attachment 4178 [details]
Preserve headers in evolution-data-server

This patch enables the PRESERVE_HEADERS option in camel/camel-mime-parser.c,
and fixes a bug in the end of headers detection that otherwise prevented this
option from working properly.
This tidies up the display of headers such as X-Spam-Report which are otherwise
difficult to read without the PRESERVE_HEADERS option enabled.
Comment 3 Craig Shelley 2007-10-28 02:40:11 UTC
This is actually caused by an issue within camel in evolution-data-server, not
spamassassin.
Comment 4 Bill Cole 2019-09-25 03:04:56 UTC
As described, not a bug  in SA at all