Bug 6005 - Add VERSION to spamd protocol
Summary: Add VERSION to spamd protocol
Status: NEW
Alias: None
Product: Spamassassin
Classification: Unclassified
Component: spamc/spamd (show other bugs)
Version: 3.2.5
Hardware: Other All
: P5 enhancement
Target Milestone: Undefined
Assignee: SpamAssassin Developer Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-27 15:52 UTC by Jorge Valdes
Modified: 2008-10-27 15:52 UTC (History)
0 users



Attachment Type Modified Status Actions Submitter/CLA Status
patch to add VERSION option to spamc/spamd patch None Jorge Valdes [NoCLA]

Note You need to log in before you can comment on or make changes to this bug.
Description Jorge Valdes 2008-10-27 15:52:16 UTC
Created attachment 4385 [details]
patch to add VERSION option to spamc/spamd

When running SPAMC/SPAMD in several servers to scan messages, we should know the version of the spamd server in order to determine what options are available. This is not generally a problem, because the SPAMD protocol rarely changes, but when the protocol changes in order to accomodate new methods, we need to know.

Using SIMSCAN as the agent calling spamd, I wanted to know the version of the spamd server in order to record the correct scanner version in the header, so I came up with a patch in order to be able to get this information, and realized that unless the spamd protocol changes, or spamc options are added, upgrades are only needed on the scanning servers, mailstores only need to have a very "recent" version of spamc in order to scan a message/file.

Also, with this new option, I will always have the correct scanner version in my simversions.cdb file my calling this option instead of getting the spamc version which may not be the same.