Bug 6899 - Mail::SpamAssassin::Plugin::SPF should have support for Authentication-Results headers
Summary: Mail::SpamAssassin::Plugin::SPF should have support for Authentication-Result...
Status: RESOLVED DUPLICATE of bug 6490
Alias: None
Product: Spamassassin
Classification: Unclassified
Component: Plugins (show other bugs)
Version: unspecified
Hardware: All All
: P2 normal
Target Milestone: Undefined
Assignee: SpamAssassin Developer Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-25 21:24 UTC by Benny Pedersen
Modified: 2018-10-19 14:45 UTC (History)
4 users (show)



Attachment Type Modified Status Actions Submitter/CLA Status

Note You need to log in before you can comment on or make changes to this bug.
Description Benny Pedersen 2013-01-25 21:24:40 UTC
Authentication-Results: duggi.junc.org; spf=pass (sender SPF authorized) smtp.mailfrom=spamassassin.apache.org (client-ip=140.211.11.3; helo=mail.apache.org; envelope-from=users-return-99356-me=junc.eu@spamassassin.apache.org; receiver=me@junc.eu)

example header
Comment 1 Kevin A. McGrail 2013-01-28 14:06:45 UTC
As a general rule, SA doesn't add extra headers.  This information might be suitable for the report information, however.
Comment 2 Benny Pedersen 2013-01-28 21:00:33 UTC
its more likely that i forgot to say Mail::SPF is missing it also, so it depends how spf plugin is configured overall, default is that is unstable in how its tested now, but i created this bug to get it common on all servers around the world, its like if there is more then one mouse hold the cat needs to find more then one hold :=)
Comment 3 Kevin A. McGrail 2013-01-28 21:21:05 UTC
(In reply to comment #2)
> its more likely that i forgot to say Mail::SPF is missing it also, so it
> depends how spf plugin is configured overall, default is that is unstable in
> how its tested now, but i created this bug to get it common on all servers
> around the world, its like if there is more then one mouse hold the cat
> needs to find more then one hold :=)

SA is more of an API for testing things and this is more of something at the MTA level.  Sorry, but I would not support SA just adding more and more headers to support more and more features (DKIM, SPF, RBLs, etc).  

I do think the information would be useful to add to the report.

Overall though if you can get a patch together or convince someone to write a patch, I would likely not stand in it's way.
Comment 4 Benny Pedersen 2013-01-30 21:50:57 UTC
its reuse of AR header like its already done with recieved-spf header i like to have supported in spf plugin
Comment 5 Kevin A. McGrail 2013-01-30 22:52:54 UTC
Benny and I have been talking and apparently this is older functionality that needs to be ported forward to the new SPF implementation.  Do we have anything in SA that uses an existing SPF header and avoids a second SPF lookup?
Comment 6 Alessandro Vesely 2013-03-06 11:21:23 UTC
(In reply to comment #5)
> Do we have anything in SA that uses an existing SPF header
> and avoids a second SPF lookup?

Mail::SpamAssassin::Plugin::SPF uses Received-SPF:, and has documented options to tweak that usage.  Authentication-Results: can be used to report SPF results as an alternative, or in addition, to Received-SPF:.

As Authentication-Results: can be used to report various results, it is better to factor parsing into a new plugin, and then have each module check whether the result it wants is already in.
Comment 7 Henrik Krohns 2018-10-19 14:45:47 UTC
Authentication-Results was already added in bug 6490.

*** This bug has been marked as a duplicate of bug 6490 ***