Bug 7018 - razor_timeout throws warnings in Parser.pm and is being skipped
Summary: razor_timeout throws warnings in Parser.pm and is being skipped
Status: RESOLVED FIXED
Alias: None
Product: Spamassassin
Classification: Unclassified
Component: Plugins (show other bugs)
Version: 3.4.0
Hardware: PC Linux
: P2 normal
Target Milestone: Undefined
Assignee: SpamAssassin Developer Mailing List
URL:
Whiteboard:
Keywords:
: 7027 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-02-26 16:44 UTC by alex
Modified: 2014-03-27 14:29 UTC (History)
2 users (show)



Attachment Type Modified Status Actions Submitter/CLA Status

Note You need to log in before you can comment on or make changes to this bug.
Description alex 2014-02-26 16:44:15 UTC
If the Razor2 plugin is enabled and "razor_timeout 20" (or any other valid number) is included in local.cf, SpamAssassin throws these errors:

Feb 26 17:12:31.696 [16499] warn: Use of uninitialized value $type in numeric eq (==) at /usr/share/perl5/vendor_perl/Mail/SpamAssassin/Conf/Parser.pm line 6
Feb 26 17:12:31.696 [16499] warn: Use of uninitialized value $type in numeric eq (==) at /usr/share/perl5/vendor_perl/Mail/SpamAssassin/Conf/Parser.pm line 6
Feb 26 17:12:31.696 [16499] warn: Use of uninitialized value $type in numeric eq (==) at /usr/share/perl5/vendor_perl/Mail/SpamAssassin/Conf/Parser.pm line 6
Feb 26 17:12:31.696 [16499] warn: Use of uninitialized value $type in numeric eq (==) at /usr/share/perl5/vendor_perl/Mail/SpamAssassin/Conf/Parser.pm line 6
Feb 26 17:12:31.696 [16499] warn: Use of uninitialized value $type in numeric eq (==) at /usr/share/perl5/vendor_perl/Mail/SpamAssassin/Conf/Parser.pm line 6
Feb 26 17:12:31.696 [16499] warn: Use of uninitialized value $type in numeric eq (==) at /usr/share/perl5/vendor_perl/Mail/SpamAssassin/Conf/Parser.pm line 6
Feb 26 17:12:31.696 [16499] warn: Use of uninitialized value $type in numeric eq (==) at /usr/share/perl5/vendor_perl/Mail/SpamAssassin/Conf/Parser.pm line 6
Feb 26 17:12:31.696 [16499] warn: Use of uninitialized value $type in numeric eq (==) at /usr/share/perl5/vendor_perl/Mail/SpamAssassin/Conf/Parser.pm line 6
Feb 26 17:12:31.696 [16499] warn: Use of uninitialized value $type in numeric eq (==) at /usr/share/perl5/vendor_perl/Mail/SpamAssassin/Conf/Parser.pm line 6
Feb 26 17:12:31.696 [16499] warn: Use of uninitialized value $type in numeric eq (==) at /usr/share/perl5/vendor_perl/Mail/SpamAssassin/Conf/Parser.pm line 6
Feb 26 17:12:31.697 [16499] warn: Use of uninitialized value $type in concatenation (.) or string at /usr/share/perl5/vendor_perl/Mail/SpamAssassin/Conf/Pars
Feb 26 17:12:31.697 [16499] warn: config: unknown conf type ! at /usr/share/perl5/vendor_perl/Mail/SpamAssassin/Conf/Parser.pm line 699.
Feb 26 17:12:31.697 [16499] warn: config: failed to parse line, skipping, in "/etc/mail/spamassassin/local.cf": razor_timeout 20


This is due to a typo in Mail/SpamAssassin/Plugin/Razor2.pm line 118:

    type => $Mail::SpamAssassin::Conf::CONF_TYPE_DURATIION,

Should be:

    type => $Mail::SpamAssassin::Conf::CONF_TYPE_DURATION,
Comment 1 Kevin A. McGrail 2014-02-27 00:50:53 UTC
Thanks, great catch Alex

svn commit -m 'Bug 7018 - Misspelling on Razor Configuration item thanks to Alex from wombaz.de'
Sending        lib/Mail/SpamAssassin/Plugin/Razor2.pm
Transmitting file data .
Committed revision 1572369.
Comment 2 Kevin A. McGrail 2014-03-27 14:29:20 UTC
*** Bug 7027 has been marked as a duplicate of this bug. ***