Bug 7444 - unescaped left brace in regex, lib/perl5/site_perl/Mail/SpamAssassin/PerMsgStatus.pm line 921
Summary: unescaped left brace in regex, lib/perl5/site_perl/Mail/SpamAssassin/PerMsgSt...
Status: RESOLVED DUPLICATE of bug 7404
Alias: None
Product: Spamassassin
Classification: Unclassified
Component: spamassassin (show other bugs)
Version: 3.4.1
Hardware: PC FreeBSD
: P2 trivial
Target Milestone: Undefined
Assignee: SpamAssassin Developer Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-05 07:51 UTC by Trond Endrestøl
Modified: 2017-07-05 14:22 UTC (History)
2 users (show)



Attachment Type Modified Status Actions Submitter/CLA Status
Patch for lib/perl5/site_perl/Mail/SpamAssassin/PerMsgStatus.pm post-Perl 5.26 patch None Trond Endrestøl [NoCLA]

Note You need to log in before you can comment on or make changes to this bug.
Description Trond Endrestøl 2017-07-05 07:51:56 UTC
Created attachment 5455 [details]
Patch for lib/perl5/site_perl/Mail/SpamAssassin/PerMsgStatus.pm post-Perl 5.26

After upgrading Perl to 5.26, it started to complain whenever spamassassin or sa-update is being run:

Unescaped left brace in regex is deprecated here (and will be fatal in Perl 5.30), passed through in regex; marked by <-- HERE in m/^(.{ <-- HERE ,200}).*$/ at
/usr/local/lib/perl5/site_perl/Mail/SpamAssassin/PerMsgStatus.pm line 921.

Patch attached.
Comment 1 Bill Cole 2017-07-05 14:15:17 UTC
1. The attached patch breaks the intended functionality of that section of code. All it does is silence the warning. 

2. This was fixed in Bug #7404 for both trunk (will-be 4.0) and the 3.4 (will-be 3.4.2) branch.

*** This bug has been marked as a duplicate of bug 7404 ***
Comment 2 Kevin A. McGrail 2017-07-05 14:22:29 UTC
Thanks Bill, you beat me to it!