Bug 7448 - Not compatible with perl 5.30
Summary: Not compatible with perl 5.30
Status: RESOLVED DUPLICATE of bug 7404
Alias: None
Product: Spamassassin
Classification: Unclassified
Component: spamassassin (show other bugs)
Version: 3.4.1
Hardware: PC Linux
: P2 normal
Target Milestone: Undefined
Assignee: SpamAssassin Developer Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-28 09:31 UTC by Christophe
Modified: 2017-08-09 21:02 UTC (History)
2 users (show)



Attachment Type Modified Status Actions Submitter/CLA Status

Note You need to log in before you can comment on or make changes to this bug.
Description Christophe 2017-07-28 09:31:54 UTC
The script `spamassassin` displays the following warning:

Unescaped left brace in regex is deprecated here (and will be fatal in Perl 5.30), passed through in regex; marked by <-- HERE in m/^(.{ <-- HERE ,200}).*$/ at /usr/share/perl5/Mail/SpamAssassin/PerMsgStatus.pm line 923.
Comment 1 Kevin A. McGrail 2017-07-28 13:18:33 UTC
Do you have the ability to test with trunk?  We've worked on this issue prior.
Comment 2 Christophe 2017-07-28 18:29:03 UTC
I cloned the repo and this is indeed fixed. How about doing a minor release so the fix end up in Linux distributions?  (Moreover release 3.4.1 is more than 2 years old...)
Comment 3 Kevin A. McGrail 2017-07-29 23:20:49 UTC
Thanks, Christophe, we are working on a release.  Follow dev@s.a.o mailing list.  I'll publish an rc before the weekend is over.
Comment 4 Kevin A. McGrail 2017-07-31 12:05:21 UTC
Well it's 8AM and light out.  I'm going to sleep now.  Will try for that RC when I wake.
Comment 5 Christophe 2017-07-31 12:25:32 UTC
Thanks for your efforts!
Comment 6 Kevin A. McGrail 2017-08-09 21:02:05 UTC
Confirmed as a duplicate.

*** This bug has been marked as a duplicate of bug 7404 ***