Bug 7733 - New plugin for Spamassassin to use Spamhaus Technology DQS
Summary: New plugin for Spamassassin to use Spamhaus Technology DQS
Status: RESOLVED DUPLICATE of bug 7734
Alias: None
Product: Spamassassin
Classification: Unclassified
Component: Plugins (show other bugs)
Version: unspecified
Hardware: PC Linux
: P2 normal
Target Milestone: Undefined
Assignee: SpamAssassin Developer Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-10 16:58 UTC by Riccardo Alfieri
Modified: 2019-07-10 18:01 UTC (History)
3 users (show)



Attachment Type Modified Status Actions Submitter/CLA Status

Note You need to log in before you can comment on or make changes to this bug.
Description Riccardo Alfieri 2019-07-10 16:58:34 UTC
Hello,

we at Spamhaus Technology have developed a plugin that add lookup funcionalities especially useful when used in combination with our DQS (Data Query Service) product.

We already announced to spamassassin-users and got a lot of feedback that helped cleaning the codebase, and we also received positive comments on performances.

As of today the latest codebase is hosted here: https://github.com/spamhaus/spamassassin-dqs

A link to the plugin has been added to the SA wiki, under the "Commercial plugin" section here: https://cwiki.apache.org/confluence/display/SPAMASSASSIN/CustomPlugins

Since the plugin wont work without the user registering a DQS key (free of charge), the plugin should not be enabled by default, but a note to the Github page should be inserted.

Looking forward to any feedback from you

Regards,
Riccardo Alfieri
Spamhaus Technology
Comment 1 Henrik Krohns 2019-07-10 17:05:44 UTC
Hello, if you are suggesting adding the plugin officially to SpamAssassin, there is really no need for it. I will be implementing all the currently missing functions for specific helo/header dnsbl checks directly in SA core. HashBL can already query body emails and uris, will look into NS checks for emails.
Comment 2 Riccardo Alfieri 2019-07-10 17:10:08 UTC
Well yes, if you can implement the functions it will be easier for sure.

I know HashBL, but I don't know if it can do what we currently do with body emails, that is taking the @domain part of it and checking it on various DNSBls.

If you can manage to add that function too we will only provide the rules for spamassassin's users that want to use them with DQS
Comment 3 Henrik Krohns 2019-07-10 17:16:36 UTC
(In reply to Riccardo Alfieri from comment #2)
> Well yes, if you can implement the functions it will be easier for sure.
> 
> I know HashBL, but I don't know if it can do what we currently do with body
> emails, that is taking the @domain part of it and checking it on various
> DNSBls.

Right, I will also be implementing domains_only or similar option for it.. all these will be looked into 4.0.0, it will take some time since I will try to make everything much more flexible, while trying to maintain some order for these, perhaps reorganizing plugins/functions/flags better. But since people still use even SpamAssassin 3.3, all this legacy baggage of different plugins and configuration clauses is terrible and most likely will require lots of if/endifs for different versions. :-)
Comment 4 Riccardo Alfieri 2019-07-10 17:31:37 UTC
Would it make sense to add it to 3.4.3 (or 3.4.4?), to have users using it before 4.0.0 is shipped?

Obviously this will depend on the timeline on 4.0.0 release
Comment 5 Henrik Krohns 2019-07-10 17:46:40 UTC
No 3.4.3 should be released as soon as possible, it's already in rc4 stage. Hopefully it will be last 3.4 release. These are too major changes for it.
Comment 6 Riccardo Alfieri 2019-07-10 17:51:46 UTC
Ok, sounds correct.

I'll keep supporting the plugin for 3.4.1-3 while waiting for the next major release. 

If you need help in porting features to 4.0.0 let me know, I'm available to help.
Comment 7 Giovanni Bechis 2019-07-10 17:56:24 UTC
(In reply to Henrik Krohns from comment #1)
> Hello, if you are suggesting adding the plugin officially to SpamAssassin,
> there is really no need for it. I will be implementing all the currently
> missing functions for specific helo/header dnsbl checks directly in SA core.
> HashBL can already query body emails and uris, will look into NS checks for
> emails.

Are you referring to Mail::SpamAssassin::Plugin::DNSEval::check_rbl_ns_from()
or to a new addiction ?
Comment 8 Henrik Krohns 2019-07-10 18:01:46 UTC
Continued in Bug 7734.

*** This bug has been marked as a duplicate of bug 7734 ***