Bug 7736 - Validate hostnames for URI/DNS functions
Summary: Validate hostnames for URI/DNS functions
Status: RESOLVED FIXED
Alias: None
Product: Spamassassin
Classification: Unclassified
Component: Libraries (show other bugs)
Version: 3.4.2
Hardware: All All
: P2 normal
Target Milestone: 4.0.0
Assignee: SpamAssassin Developer Mailing List
URL:
Whiteboard:
Keywords:
: 7651 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-07-10 19:14 UTC by Henrik Krohns
Modified: 2019-08-03 14:12 UTC (History)
1 user (show)



Attachment Type Modified Status Actions Submitter/CLA Status

Note You need to log in before you can comment on or make changes to this bug.
Description Henrik Krohns 2019-07-10 19:14:50 UTC
Need to validate hostnames conforming to standards (each component max 63 chars, total length etc).

- schemeless parser
- header :host :domain
- askdns/dnseval/uridnsbl/bgsend_and_start_lookup/etc
Comment 1 Henrik Krohns 2019-07-12 08:39:29 UTC
*** Bug 7651 has been marked as a duplicate of this bug. ***
Comment 2 Henrik Krohns 2019-08-03 14:12:15 UTC
Part of this update.

Sending        spamassassin-3.4/UPGRADE
Sending        spamassassin-3.4/lib/Mail/SpamAssassin/DnsResolver.pm
Sending        spamassassin-3.4/lib/Mail/SpamAssassin/PerMsgStatus.pm
Sending        spamassassin-3.4/lib/Mail/SpamAssassin/RegistryBoundaries.pm
Sending        spamassassin-3.4/lib/Mail/SpamAssassin/Util.pm
Sending        spamassassin-3.4/t/uri.t
Sending        spamassassin-3.4/t/uri_text.t
Sending        trunk/UPGRADE
Sending        trunk/lib/Mail/SpamAssassin/DnsResolver.pm
Sending        trunk/lib/Mail/SpamAssassin/PerMsgStatus.pm
Sending        trunk/lib/Mail/SpamAssassin/Plugin/URIDNSBL.pm
Sending        trunk/lib/Mail/SpamAssassin/RegistryBoundaries.pm
Sending        trunk/lib/Mail/SpamAssassin/Util.pm
Sending        trunk/t/uri.t
Sending        trunk/t/uri_text.t
Transmitting file data ...............done
Committing transaction...
Committed revision 1864336.