Bug 79 - Spamassassin 2.11 is not compatible with new razor-agents 1.20
Summary: Spamassassin 2.11 is not compatible with new razor-agents 1.20
Status: RESOLVED FIXED
Alias: None
Product: Spamassassin
Classification: Unclassified
Component: Libraries (show other bugs)
Version: 2.30CVS
Hardware: PC FreeBSD
: P2 major
Target Milestone: ---
Assignee: Craig Hughes
URL:
Whiteboard:
Keywords:
: 178 179 (view as bug list)
Depends on:
Blocks:
 
Reported: 2002-03-04 09:19 UTC by Andrey A. Chernov
Modified: 2002-06-15 03:58 UTC (History)
1 user (show)



Attachment Type Modified Status Actions Submitter/CLA Status

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey A. Chernov 2002-03-04 09:19:07 UTC
Razor::Client->new fails with new razor-agents 1.20 because the code few lines 
above replace default line separator \n (which is needed for Razor to read 
servers list). 

BTW, in new Razor I not find any code which damage global $/, only local one.

Use following patch to fix it:

--- lib/Mail/SpamAssassin/Dns.pm.bak    Wed Jan  9 00:18:48 2002
+++ lib/Mail/SpamAssassin/Dns.pm        Mon Mar  4 19:49:15 2002
@@ -176,7 +176,6 @@
     require Razor::Client;
     require Razor::Agent;
     local ($^W) = 0;           # argh, warnings in Razor
-    local ($/);                        # argh, bugs in Razor

     local $SIG{ALRM} = sub { die "alarm\n" };
     alarm 10;
--- lib/Mail/SpamAssassin/Reporter.pm.bak       Wed Jan  9 00:18:48 2002
+++ lib/Mail/SpamAssassin/Reporter.pm   Mon Mar  4 19:52:11 2002
@@ -93,7 +93,6 @@
     require Razor::Client;
     require Razor::Agent;
     local ($^W) = 0;            # argh, warnings in Razor
-    local ($/);                 # argh, bugs in Razor

     local $SIG{ALRM} = sub { die "alarm\n" };
     alarm 10;
Comment 1 Craig Hughes 2002-03-04 10:16:31 UTC
Thanks for tracking this down and sending patch.  Included in CVS now.
Comment 2 Duncan Findlay 2002-04-04 19:14:03 UTC
*** Bug 179 has been marked as a duplicate of this bug. ***
Comment 3 Craig Hughes 2002-04-05 00:00:23 UTC
*** Bug 178 has been marked as a duplicate of this bug. ***