Bug 7957 - sa-update fails with regex fail for __URI_TRY_3LD
Summary: sa-update fails with regex fail for __URI_TRY_3LD
Status: RESOLVED DUPLICATE of bug 7956
Alias: None
Product: Spamassassin
Classification: Unclassified
Component: sa-update (show other bugs)
Version: unspecified
Hardware: PC Linux
: P2 blocker
Target Milestone: Undefined
Assignee: SpamAssassin Developer Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-02-19 08:04 UTC by Peter Collinson
Modified: 2022-02-19 08:16 UTC (History)
1 user (show)



Attachment Type Modified Status Actions Submitter/CLA Status

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Collinson 2022-02-19 08:04:25 UTC
sa-update version 3.4.2 / svn1840377
  running on Perl version 5.28.1

The system is Debian 10.11

sa-update -v says:

Update available for channel updates.spamassassin.org: 1898122 -> 1898171
http: (curl) GET http://sa-update.ena.com/1898171.tar.gz, success
http: (curl) GET http://sa-update.ena.com/1898171.tar.gz.sha512, success
http: (curl) GET http://sa-update.ena.com/1898171.tar.gz.sha256, success
http: (curl) GET http://sa-update.ena.com/1898171.tar.gz.asc, success
config: invalid regexp for __URI_TRY_3LD 'm,^https?://(?:try(?!r\.codeschool)|start|get(?!\.adobe)|save|check(?!out)|act|compare|join|learn(?!ing)|request|visit(?!or|\.vermont)|my(?!sub|turbotax|news\.apple|a\.godaddy|account|support|build|blob)\w)[^.]*\.[^/]+\.(?<!list-manage\.)(?:com|net)\b,i': Variable length lookbehind not implemented in regex m/(?i)^https?://(?:try(?!r\.codeschool)|start|get(?!\.adobe)|save|check(?!out)|act|compare|join|learn(?!ing)|request|vi.../
channel: lint check of update failed, channel failed
Update failed, exiting with code 4
Comment 1 Henrik Krohns 2022-02-19 08:16:05 UTC
Already fixed in Bug 7956

*** This bug has been marked as a duplicate of bug 7956 ***