View | Details | Raw Unified | Return to bug 56283
Collapse All | Expand All

(-)java/org/apache/catalina/startup/TldConfig.java (+2 lines)
Lines 94-99 Link Here
94
        noTldJars.add("ecj-4.2.1.jar");
94
        noTldJars.add("ecj-4.2.1.jar");
95
        noTldJars.add("ecj-4.2.2.jar");
95
        noTldJars.add("ecj-4.2.2.jar");
96
        noTldJars.add("ecj-4.3.1.jar");
96
        noTldJars.add("ecj-4.3.1.jar");
97
        noTldJars.add("ecj-4.3.2.jar");
98
        noTldJars.add("ecj-P20140317-1600.jar");
97
        noTldJars.add("jsp-api.jar");
99
        noTldJars.add("jsp-api.jar");
98
        noTldJars.add("servlet-api.jar");
100
        noTldJars.add("servlet-api.jar");
99
        noTldJars.add("tomcat-coyote.jar");
101
        noTldJars.add("tomcat-coyote.jar");
(-)java/org/apache/jasper/compiler/JDTCompiler.java (+8 lines)
Lines 310-315 Link Here
310
            } else if(opt.equals("1.7")) {
310
            } else if(opt.equals("1.7")) {
311
                settings.put(CompilerOptions.OPTION_Source,
311
                settings.put(CompilerOptions.OPTION_Source,
312
                             CompilerOptions.VERSION_1_7);
312
                             CompilerOptions.VERSION_1_7);
313
            } else if(opt.equals("1.8")) {
314
                settings.put(CompilerOptions.OPTION_Source,
315
                             "1.8"); // CompilerOptions.VERSION_1_8
313
            } else {
316
            } else {
314
                log.warn("Unknown source VM " + opt + " ignored.");
317
                log.warn("Unknown source VM " + opt + " ignored.");
315
                settings.put(CompilerOptions.OPTION_Source,
318
                settings.put(CompilerOptions.OPTION_Source,
Lines 351-356 Link Here
351
                             CompilerOptions.VERSION_1_7);
354
                             CompilerOptions.VERSION_1_7);
352
                settings.put(CompilerOptions.OPTION_Compliance,
355
                settings.put(CompilerOptions.OPTION_Compliance,
353
                        CompilerOptions.VERSION_1_7);
356
                        CompilerOptions.VERSION_1_7);
357
            } else if(opt.equals("1.8")) {
358
                settings.put(CompilerOptions.OPTION_TargetPlatform,
359
                        "1.8"); // CompilerOptions.VERSION_1_8
360
                settings.put(CompilerOptions.OPTION_Compliance,
361
                        "1.8"); // CompilerOptions.VERSION_1_8
354
            } else {
362
            } else {
355
                log.warn("Unknown target VM " + opt + " ignored.");
363
                log.warn("Unknown target VM " + opt + " ignored.");
356
                settings.put(CompilerOptions.OPTION_TargetPlatform,
364
                settings.put(CompilerOptions.OPTION_TargetPlatform,
(-)java/org/apache/jasper/compiler/TldLocationsCache.java (+2 lines)
Lines 134-139 Link Here
134
        noTldJars.add("ecj-4.2.1.jar");
134
        noTldJars.add("ecj-4.2.1.jar");
135
        noTldJars.add("ecj-4.2.2.jar");
135
        noTldJars.add("ecj-4.2.2.jar");
136
        noTldJars.add("ecj-4.3.1.jar");
136
        noTldJars.add("ecj-4.3.1.jar");
137
        noTldJars.add("ecj-4.3.2.jar");
138
        noTldJars.add("ecj-P20140317-1600.jar");
137
        noTldJars.add("jsp-api.jar");
139
        noTldJars.add("jsp-api.jar");
138
        noTldJars.add("servlet-api.jar");
140
        noTldJars.add("servlet-api.jar");
139
        noTldJars.add("tomcat-coyote.jar");
141
        noTldJars.add("tomcat-coyote.jar");

Return to bug 56283