Thu Jun 20 2019 03:03:42 UTC
the box said: "Requires Windows9x,Me,Nt,2000 or better" . So I installed Linux !
Hide Search Description
Zarro Boogs found.
as