Bug 15728

Summary: property values with XML have incorrect namespaces
Product: Apache httpd-2 Reporter: Chris Knight <Christopher.D.Knight>
Component: mod_davAssignee: Apache HTTPD Bugs Mailing List <bugs>
Status: CLOSED DUPLICATE    
Severity: normal    
Priority: P3    
Version: 2.0.43   
Target Milestone: ---   
Hardware: Other   
OS: other   

Description Chris Knight 2002-12-31 00:20:43 UTC
In doing a PROPPATCH like:

<?xml version="1.0" encoding="utf-8"?><D:propertyupdate
xmlns:D="DAV:"
xmlns:alpha="http://www.arc.nasa.gov/"
xmlns:custom="http://webdav.org/cadaver/custom-properties/"
><D:set>
<D:prop>
<custom:foo>
<alpha:bar>baz</alpha:bar></custom:foo>
</D:prop></D:set></D:propertyupdate>

The subsequent PROPFIND returns (note that while the proper namespace alias has
been defined (ns2), the incorrect namespace is used (ns0)):

<?xml version="1.0" encoding="utf-8"?>
<D:multistatus xmlns:D="DAV:">
<D:response xmlns:ns0="DAV:"
xmlns:ns1="http://webdav.org/cadaver/custom-properties/"
xmlns:ns2="http://www.arc.nasa.gov/" xmlns:lp1="DAV:"
xmlns:lp2="http://apache.org/dav/props/">
<D:href>/davfs/</D:href>
<D:propstat>
<D:prop>
<ns1:foo>
<ns0:bar>baz</ns0:bar></ns1:foo>
<lp1:resourcetype><D:collection/></lp1:resourcetype>
<lp1:creationdate>2002-12-31T00:03:08Z</lp1:creationdate>
<lp1:getlastmodified>Tue, 31 Dec 2002 00:03:08 GMT</lp1:getlastmodified>
<lp1:getetag>"42d2d-200-eaa82700"</lp1:getetag>
<D:supportedlock>
<D:lockentry>
<D:lockscope><D:exclusive/></D:lockscope>
<D:locktype><D:write/></D:locktype>
</D:lockentry>
<D:lockentry>
<D:lockscope><D:shared/></D:lockscope>
<D:locktype><D:write/></D:locktype>
</D:lockentry>
</D:supportedlock>
<D:lockdiscovery/>
<D:getcontenttype>httpd/unix-directory</D:getcontenttype>
</D:prop>
<D:status>HTTP/1.1 200 OK</D:status>
</D:propstat>
</D:response>
</D:multistatus>
Comment 1 Joe Orton 2003-03-18 21:03:02 UTC

*** This bug has been marked as a duplicate of 11637 ***