Bug 24459

Summary: Mod Expires generates internal error
Product: Apache httpd-2 Reporter: Sander Holthaus <info>
Component: mod_expiresAssignee: Apache HTTPD Bugs Mailing List <bugs>
Status: CLOSED DUPLICATE    
Severity: normal    
Priority: P3    
Version: 2.0.48   
Target Milestone: ---   
Hardware: PC   
OS: Linux   

Description Sander Holthaus 2003-11-06 10:54:24 UTC
After upgrading from Apache 2.0.45 to 2.0.48, I started receiving the followin 
error:

internal error: bad expires code: /usr/local/www/domain.com/docs/robot.txt

Very akward, since the document in question was not using mod_expires.

I have the follwing in my httpd.conf

        ExpiresActive On
        ExpiresByType text/html A86400
        ExpiresByType text/css A604800
        ExpiresByType application/x-javascript A604800
        ExpiresByType image/gif A2678400
        ExpiresByType image/jpeg A2678400
        ExpiresByType image/x-icon A5356800

Output of httpd -l:

        Compiled in modules:
          core.c
          mod_access.c
          mod_deflate.c
          mod_env.c
          mod_expires.c
          mod_headers.c
          mod_unique_id.c
          mod_setenvif.c
          prefork.c
          http_core.c
          mod_alias.c
          mod_rewrite.c
          mod_so.c

The change I made from upgrading to 2.0.48 is statically compiling in 
mod_expires (among others). The problem / error was solved by putting in an 
ExpiresDefault in the httpd.conf.
Comment 1 buggy 2003-11-21 20:22:03 UTC
I'm also getting this error logged.

For some reason it expects a expires date for EVERY file. They way I solved it 
was by using the ExpiresDefault directive.

This is not an ideal solution.
Comment 2 Paul J. Reder 2003-11-21 23:05:40 UTC

*** This bug has been marked as a duplicate of 23748 ***
Comment 3 Paul J. Reder 2003-11-21 23:48:55 UTC
The patch in 23748 (which this is a duplicate of) has been committed to the
2.1-dev branch of Apache. It has also been submitted for a backport vote into
the 2.0 stable branch.

Thank you for using Apache and for taking the time to report this bug.