Bug 50511

Summary: WARNING about Internal Dummy Connection of Apache
Product: Tomcat Connectors Reporter: kikuchi yu <kikuchi.yu>
Component: mod_jkAssignee: Tomcat Developers Mailing List <dev>
Status: RESOLVED FIXED    
Severity: normal CC: chris
Priority: P2    
Version: 1.2.30   
Target Milestone: ---   
Hardware: Other   
OS: Linux   
Attachments: ignore the request which uri matches "*"

Description kikuchi yu 2010-12-22 00:00:19 UTC
When my system is highly-loaded, the messeges are printed in mod_jk.log.

[mod_jk.log]
[Tue Dec 21 11:31:25.958 2010] [4744:3086915888] [warn] map_uri_to_worker_ext::jk_uri_worker_map.c (962): Uri * is
invalid. Uri must start with /

I assume the messages are caused by Internal Dummy Connection of Apache by the access_log.

[access_log]
::1 - - [21/Dec/2010:11:31:25 +0900] "OPTIONS * HTTP/1.0" 200 -

The OPTIONS request is valid, but mod_jk forejudges it as a WARNING.

I made small patch when the uri of request matches '*', mod_jk doesn't print WARNING log.

But I think it should be adjusted by the category of methods.
(For example, if method is OPTIONS and uri is '*', debug message would output.)

Best regards,
Comment 1 kikuchi yu 2010-12-22 00:02:09 UTC
Created attachment 26438 [details]
ignore the request which uri matches "*"
Comment 2 Christopher Schultz 2010-12-22 12:19:31 UTC
Please see http://markmail.org/thread/gmqxxlcoop6ijuoj for discussion on the user list.

I'm not convinced this is a mod_jk problem, yet.
Comment 3 Rainer Jung 2010-12-22 13:13:00 UTC
Since this is well-known behaviour of Apache, it would be nice if mod_jk would tolerate those dummy requests instead of filling the log file with warnings. In this special case there's nothing to warn about.
Comment 4 Christopher Schultz 2010-12-22 13:45:05 UTC
It seems like a request for "*" should never be mapped to mod_jk in the first place. Does "JkMount /*" match a bare "*" (with no leading /)?
Comment 5 William A. Rowe Jr. 2010-12-22 14:09:02 UTC
Without support for OPTIONS * HTTP/1.1 - it's going tot be impossible to discern
what additional methods are exposed by Tomcat, e.g. DAV directives.  Consider
this as a solution between Tomcat and mod_jk is sought.
Comment 6 Mladen Turk 2012-05-07 08:17:11 UTC
Please use the latest release (1.2.35)
Comment 7 Ross Richardson 2014-12-04 22:52:22 UTC
This message is still occurring in 1.2.40. What was the resolution on this?
This message is filling the jk log too much.
Comment 8 Rainer Jung 2014-12-05 01:56:51 UTC
The change is in

http://svn.apache.org/viewvc?view=revision&revision=1598864

This has not been released yet but will be part of version 1.2.41. Until that version will be released (I plan to start the release cycle in a few weeks), you can include that simple patch if you do your own build.

Regards,

Rainer
Comment 9 Rainer Jung 2014-12-30 15:07:06 UTC
*** Bug 57405 has been marked as a duplicate of this bug. ***
Comment 10 Christopher Schultz 2014-12-30 15:27:45 UTC
(In reply to Rainer Jung from comment #9)
> *** Bug 57405 has been marked as a duplicate of this bug. ***

Thanks for finding this... I was positive it was in BZ somewhere but couldn't find it because it was a) filed using different description and b) already fixed but c) not yet released.