Bug 54006

Summary: Webservice Sampler : Response status 500 is not considered as an error due to soap-2.3.1 limitation
Product: JMeter Reporter: Philippe Mouawad <p.mouawad>
Component: HTTPAssignee: JMeter issues mailing list <issues>
Status: RESOLVED WONTFIX    
Severity: normal CC: p.mouawad
Priority: P2    
Version: 2.3.3   
Target Milestone: ---   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 53978    
Attachments: Sample Tesrt Plan using Mirror Server to show issue

Description Philippe Mouawad 2012-10-14 13:58:52 UTC
While working on :
53978 	SoapSampler : Add an option to allow empty response as successful result 

I noticed that sampler did not check response status, so a 500 Internal Server response is considered successful.

It seems it is known since 2.3.3 when empty response began to be considered as an error.

But this should be mentionned in Known issues
Comment 1 Philippe Mouawad 2012-10-14 14:03:09 UTC
Created attachment 29475 [details]
Sample Tesrt Plan using Mirror Server to show issue
Comment 2 Philippe Mouawad 2012-10-14 17:00:34 UTC
This seems to be unfixable unless we :
- change soap.jar version ? but where is it located
- change implementation of Soap Clien (Apache CXF ?)

The issue is that the class used by transport:
- http://kickjava.com/src/org/apache/soap/util/net/HTTPUtils.java

fills status String but does not return it, so issue could be fixed by fixing the library to return this status.
Comment 3 Philippe Mouawad 2012-10-14 17:31:58 UTC
Exists since the beginning and up to current version 2.8
Comment 4 Philippe Mouawad 2012-11-12 20:45:59 UTC
Soap Sampler is deprecated as of upcoming version JMeter 2.9