Bug 55857

Summary: Performance : AbstractProperty should test for emptiness to avoid Exception throwing
Product: JMeter Reporter: Philippe Mouawad <p.mouawad>
Component: HTTPAssignee: JMeter issues mailing list <issues>
Status: RESOLVED FIXED    
Severity: enhancement CC: p.mouawad
Priority: P2    
Version: 2.6   
Target Milestone: ---   
Hardware: All   
OS: All   

Description Philippe Mouawad 2013-12-08 14:40:27 UTC
Profiling application I see thousands of NumberFormatException thrown during a Test using HttpSampler.

Root cause is getIntValue parsing an empty field and only testing for nullity instead of also testing for emptiness.
Comment 1 Philippe Mouawad 2013-12-08 14:41:15 UTC
This bug affects all versions of JMeter up to 2.10
Comment 2 Philippe Mouawad 2013-12-08 14:43:49 UTC
Date: Sun Dec  8 14:43:05 2013
New Revision: 1549031

URL: http://svn.apache.org/r1549031
Log:
Bug 55857 - Performance : AbstractProperty should test for emptiness to avoid Exception throwing
Bugzilla Id: 55857

Modified:
    jmeter/trunk/src/core/org/apache/jmeter/testelement/property/AbstractProperty.java
    jmeter/trunk/xdocs/changes.xml