Bug 57043

Summary: Undo/Redo is called "abusively" and has very bad impact on performances of JMeter
Product: JMeter Reporter: Philippe Mouawad <p.mouawad>
Component: MainAssignee: JMeter issues mailing list <issues>
Status: RESOLVED DUPLICATE    
Severity: normal CC: apc4, c.andersen2012, emi, marco.porrelli, p.mouawad
Priority: P2    
Version: Nightly (Please specify date)   
Target Milestone: ---   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 42248    

Description Philippe Mouawad 2014-09-29 19:16:28 UTC
As per Ubik Load Pack support report :
- Undo/Redo is called "abusively" when for example you:
1) Search for a node by name
2) In Module Controller GUI, when you expand a node
Comment 1 Philippe Mouawad 2014-10-02 19:57:28 UTC
Hello,
I notice big slowdowns of JMeter with nightly build related to Undo/Redo feature.
Scenario:
- I load a Test Plan with something like 218 elements (1.5m)
- I takes around 23 seconds to load with nightly vs 1.5 seconds on 2.11 on a MacBook Pro 2.7 Ghz Intel Core i7 16 Gb and -Xms2g -Xmx3g

Analyzing this, it is related to the fact that UndoHistory#add is called for every addition of a node (> 218 times) , an entry is added in history and finally undoHistory is cleaned up.

With default settings (I disabled by default undo, I get same load time as 2.10).

We need to improve the undo algorithm.
Regards
Comment 2 Philippe Mouawad 2014-10-02 20:02:43 UTC
Affects Nightly (before 2.12) of 2th October 2014
Comment 3 Philippe Mouawad 2015-12-09 20:44:00 UTC
*** Bug 58707 has been marked as a duplicate of this bug. ***
Comment 4 Philippe Mouawad 2015-12-14 19:53:43 UTC
*** Bug 58734 has been marked as a duplicate of this bug. ***
Comment 5 Philippe Mouawad 2018-10-28 11:06:22 UTC
This has been improved by Emilian Bold work within Bug 57039

*** This bug has been marked as a duplicate of bug 57039 ***