Bug 57185

Summary: Chart "serie" should be "series"
Product: POI Reporter: Philippe Lhoste <PhiLho>
Component: POI OverallAssignee: POI Developers List <dev>
Status: RESOLVED FIXED    
Severity: normal    
Priority: P2    
Version: 3.11-dev   
Target Milestone: ---   
Hardware: PC   
OS: All   

Description Philippe Lhoste 2014-11-04 18:06:50 UTC
As a French, that' something I had difficulties to assimilate, but now I know that the word "serie" doesn't exist in English (rechecked with Merriam-Webster...), it is an invariant name "series" (not very practical for programming purpose, we have to make seriesList instead of using a plural name, etc.).

Exploring the new, beta feature of adding charts to Excel worksheets, I stumble upon a class:

/**
 * Represents a line chart serie.
 *
 * @author Martin Andersson
 */
@Beta
public interface LineChartSerie extends ChartSerie {
...
}

While it is in beta state, I suggest to rename them to ChartSeries and LineChartSeries.
Comment 1 Nick Burch 2014-11-04 22:49:32 UTC
Thanks, fixed in r1636755.