Bug 63002

Summary: QSD in RewriteRule doesn't work
Product: Tomcat 8 Reporter: Melvin A <melvindoss>
Component: CatalinaAssignee: Tomcat Developers Mailing List <dev>
Status: RESOLVED FIXED    
Severity: normal    
Priority: P2    
Version: 8.5.35   
Target Milestone: ----   
Hardware: PC   
OS: Mac OS X 10.1   

Description Melvin A 2018-12-11 10:48:42 UTC
Hi there, 

QSD flag added to any RewriteRule doesn't work. 

RewriteRule ^/app1/(.*)$ /app1/rewrite.jsp [L,QSD]

this is my only line in rewrite.config, When I give http://localhost:8080/app1/test.jsp?value=single as the request, the ideal behaviour must discard the querystring and go to rewrite.jsp.

But it doesn't and I found the cause. Hope 1845673 is the revision of tomcat 8.5.35. In java/org/apache/catalina/valves/rewrite/RewriteValve.java line 785, rule is set for qsAppend instead of qsDiscard. Do the needful.

Regards,

Melvin A
Comment 1 Remy Maucherat 2018-12-11 11:58:56 UTC
Bad cut & paste ... The fix will be in 9.0.14 and 8.5.36.