Bug 10422

Summary: htpasswd overwrites last user, no more users can be added
Product: Apache httpd-2 Reporter: William Campbell <campbill>
Component: mod_authAssignee: Apache HTTPD Bugs Mailing List <bugs>
Status: CLOSED FIXED    
Severity: normal CC: mike.soules, noackjr
Priority: P3    
Version: 2.0.39   
Target Milestone: ---   
Hardware: PC   
OS: Linux   

Description William Campbell 2002-07-02 19:32:05 UTC
htpasswd in 2.039 does not add new users, it just replaces the last one
(from the command line).  This occurs both before and after applying the (-c -n 

    htpasswd from 1.3.24 can be used successfully with httpd 2.0.39
Comment 1 Ryan Bloom 2002-07-02 19:50:16 UTC
Fixed in CVS, we weren't adding a newline at the end of each record.
Comment 2 Cliff Woolley 2002-07-02 19:54:48 UTC
*** Bug 10221 has been marked as a duplicate of this bug. ***
Comment 3 Jon Noack 2002-07-08 06:08:35 UTC
Why did no one look at bug 10221?  I had this issue fixed via an attached patch 
on 6/27, while it was fixed in CVS until 7/2.  Basically, I'm just wondering 
what, if anything, I need to do differently to be heard.
Comment 4 William Campbell 2002-07-08 13:32:10 UTC
I searched the database for this problem and saw nothing similar, otherwise I 
would not have posted it.
Comment 5 André Malo 2003-03-01 21:02:55 UTC
Just a word. People actually try to track the bug db, but it's mostly done in
their spare time, which is quite limited, as you may guess.

Thanks for your reports and for using Apache.