Bug 10734

Summary: A documentation bug for import element
Product: Taglibs Reporter: Kevin Jones <kevinj>
Component: Standard TaglibAssignee: Tomcat Developers Mailing List <dev>
Status: RESOLVED INVALID    
Severity: minor CC: dmeranda
Priority: P3    
Version: 1.0   
Target Milestone: ---   
Hardware: Other   
OS: other   

Description Kevin Jones 2002-07-12 12:52:43 UTC
Not sure if this should be posted here. The documention for the import tag 
says that the type of varReader is string, the description says Reader.
Comment 1 Pierre Delisle 2002-07-12 17:22:40 UTC
The description for "varReader" says:
  Name of the exported scoped variable for the resource's content. 
  The type of the scoped variable is Reader.

There are therefore two things here: 
  1. The value of attribute varReader, which is a String
     representing the name of the exported scoped variable
  2. The type associated with the exported scoped variable,
     which is Reader.

So when the spec says:
  "It is also possible to make the content of the resource available 
   in two different ways: as a String object (attribute var), or as 
   a Reader object (attribute varReader)."

both var and varReader specify the names of exported scoped variables
(specified as strings), but the type of these exported variables 
are respectively String and Reader.
Comment 2 Joe Orton 2004-03-09 23:55:42 UTC
*** Bug 26088 has been marked as a duplicate of this bug. ***