Bug 13748

Summary: Need to expose exception thrown by bean accessor as part of EL expression evaluation
Product: Taglibs Reporter: Jan Luehe <jan.luehe>
Component: Standard TaglibAssignee: Tomcat Developers Mailing List <dev>
Status: RESOLVED FIXED    
Severity: enhancement    
Priority: P3    
Version: unspecified   
Target Milestone: ---   
Hardware: Other   
OS: other   

Description Jan Luehe 2002-10-17 19:12:19 UTC
If a bean property gets accessed as part of an EL expression evaluation, and the
bean accessor throws an exception, that exception currently does not get exposed
by the JspException that is thrown by
org.apache.taglibs.standard.lang.jstl.Evaluator.evaluate() after catching the
ELException.

However, that exception may contain information that could be very useful in
tracking down the root cause of the failure (e.g., the accessor may involve
connecting to a database, in which case it would be useful to expose the SQL
exception in case things go wrong).
Comment 1 Jan Luehe 2002-10-17 19:14:07 UTC
Fixed and integrated in Standard Taglib 1.0.2.