Bug 14487

Summary: worksheet cloning doesn't work until all records implement clone
Product: POI Reporter: Dennis Doubleday <dennis>
Component: HSSFAssignee: POI Developers List <dev>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: P3    
Version: 2.0-dev   
Target Milestone: ---   
Hardware: All   
OS: other   

Description Dennis Doubleday 2002-11-12 19:20:13 UTC
I attempted to use the HSSFWorkbook.cloneSheet() method and got:

java.lang.RuntimeException: The class
org.apache.poi.hssf.record.ColumnInfoRecord needs to define a clone method

	at org.apache.poi.hssf.record.Record.clone(Record.java:247)
	at org.apache.poi.hssf.model.Sheet.cloneSheet(Sheet.java:282)
	at org.apache.poi.hssf.usermodel.HSSFSheet.cloneSheet(HSSFSheet.java:147)
	at  org.apache.poi.hssf.usermodel.HSSFWorkbook.cloneSheet(HSSFWorkbook.java:341)
Comment 1 Avik Sengupta 2002-12-13 04:49:14 UTC

*** This bug has been marked as a duplicate of 15050 ***