Bug 15353

Summary: [RFE] creating a cell with a hyperlink
Product: POI Reporter: Nicklas Lundgren <nicklas.lundgren>
Component: HSSFAssignee: POI Developers List <dev>
Status: RESOLVED FIXED    
Severity: normal CC: alon, eric, midpeter, phani
Priority: P3    
Version: unspecified   
Target Milestone: ---   
Hardware: PC   
OS: All   

Description Nicklas Lundgren 2002-12-13 13:51:53 UTC
I tried to create a cell with a hyperlink in it. When I open the file there is 
no link only the text for creating the hyperlink. Is this a known problem?

HSSFWorkbook wb = new HSSFWorkbook();
HSSFSheet sheet = wb.createSheet("My sheet");

HSSFRow row = sheet.createRow( (short) 0 );
HSSFCell cell = row.createCell( (short) 0 );
cell.setCellValue("=HYPERLINK(\"http.google.com\";\"Google\")");
        
// Write out the workbook
FileOutputStream fileOut = new FileOutputStream("c:\\workbook.xls");
wb.write(fileOut);
fileOut.close();
Comment 1 Avik Sengupta 2002-12-21 07:15:59 UTC
Part of the unresolved string formula issues, i presume. 
Comment 2 Danny Mui 2003-02-25 03:35:34 UTC
*** Bug 9631 has been marked as a duplicate of this bug. ***
Comment 3 Alon Salant 2003-06-19 22:12:54 UTC
http://www.mail-archive.com/poi-user@jakarta.apache.org/msg00077.html

Direction on how to address this from Andy:

<snip>
If you don't want to wait on us, all that needs to be done is simply create
a low level record for what I think is called HLINK in the Excel 97
Developer's kit, then add it to the high level model (probably new cell
type).. 
</snip>

-alon
Comment 4 Andy Oliver 2003-06-26 18:49:19 UTC
*** Bug 21118 has been marked as a duplicate of this bug. ***
Comment 5 Andy Oliver 2003-06-26 18:50:22 UTC
*** Bug 20548 has been marked as a duplicate of this bug. ***
Comment 6 tony.l.reller 2003-08-01 13:47:16 UTC
Any feel as to when this will be resolved?. Would really like to have this 
feature by October.
Comment 7 Andy Oliver 2003-08-01 13:58:39 UTC
SuperLink had a client funding this effort but the deal fell through so it will be when someone 
steps up and volunteers.  I've tried to assign deadlines to developers I'm not paying in the 
past...doesn't work that way.
Comment 8 Avik Sengupta 2003-10-06 10:08:01 UTC
As a workaround , why dont you use the HYPERLINK formula?
Comment 9 Avik Sengupta 2003-10-06 10:22:52 UTC
Sorry, disregard my last comment. But:

     cell.setCellFormula("HYPERLINK(\"http://google.com\",\"Google\")");

does indeed work! As proof, see test15353 in o.a.p.h.u.TestBugs.java

Also see 23094