Bug 1551

Summary: delete task follow symbolic links
Product: Ant Reporter: michele.quaini
Component: Core tasksAssignee: Ant Notifications List <notifications>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: P1    
Version: 1.3   
Target Milestone: ---   
Hardware: Sun   
OS: other   

Description michele.quaini 2001-04-27 00:51:40 UTC
i made a simbolic lynk under the directory webapps/<project>, 
containg some files to be displayed

> cd $TOMCAT_HOME/webapps/<project>
> ln -s /usr/local/.../invoices invoices

Executing the following target clean:

> build clean


it followed the symbolic link, deleting the entire directory content.

content of build.xml:


...
  <target name="clean">
    <delete dir="${deploy.home}"/>
  </target>
...
Comment 1 michele.quaini 2001-04-27 00:52:24 UTC

*** This bug has been marked as a duplicate of 1550 ***