Bug 15556

Summary: SSTDeserialise error (was: Unknown Ptg error occurrs)
Product: POI Reporter: Young Hoon, Park <manager>
Component: HSSFAssignee: POI Developers List <dev>
Status: RESOLVED DUPLICATE    
Severity: critical    
Priority: P3    
Version: 3.0-dev   
Target Milestone: ---   
Hardware: Other   
OS: other   
Attachments: this is excel file that make problem.

Description Young Hoon, Park 2002-12-20 05:34:25 UTC
POIFSFileSystem fs  = new POIFSFileSystem(new FileInputStream(file)); 
HSSFWorkbook wb = new HSSFWorkbook(fs);  
  // after this has been executed, next error message come out and ..

		OPTIONS = 10
		OPTIONS & 0x10 = 16
		OPTIONS = 10
		OPTIONS & 0x10 = 16
		[WARNING] Unknown Ptg e (14) at cell (38,88)
		[WARNING] Unknown Ptg e (14) at cell (39,88)
		OPTIONS = 10
		OPTIONS & 0x10 = 16
		OPTIONS = 10
		OPTIONS & 0x10 = 16
		[WARNING] Unknown Ptg e (14) at cell (38,88)
		[WARNING] Unknown Ptg e (14) at cell (39,88)

HSSFSheet sheet = null;
HSSFRow row =  null;
HSSFCell cell = null;

row = sheet.getRow(45); // at here next error occurrs and can't proceed more.

                java.lang.NullPointerException
Comment 1 Young Hoon, Park 2002-12-20 05:39:36 UTC
Created attachment 4234 [details]
this is excel file that make problem.
Comment 2 Avik Sengupta 2003-01-05 06:55:47 UTC
"Unknown Ptg" warning is expected, since POI cannot at the moment read logical
formulaes. The null pointer exception is has nothing to do with that. IF the
code you have pasted here is what you are running, then you WILL get such an
exception, since your "sheet" variable IS null. You need to assing to sheet as
sheet=wb.getSheetAt(0); 
that should work for you. 

BTW, which version of POI are you using?
Comment 3 Avik Sengupta 2003-01-05 07:00:06 UTC
Right, the bug as reported is invalid (see comment above). However, the attached
spreadsheet throws up another issue. 

In the latest CVS, poi throws a java.lang.NegativeArraySizeException
        at org.apache.poi.hssf.record.SSTDeserializer.readStringRemainder(SSTDes
erializer.java:335)

I believe that the proximate cause is that the sheet contains Korean encodings. 
Any ideas??

Therefore reopening. 

Comment 4 Andy Oliver 2003-07-24 14:08:30 UTC
This looks complicated.  Might be best off in 3.0.  
Comment 5 Avik Sengupta 2003-07-31 20:28:14 UTC
Confirmed: Bug still exists in 2.0pre3
Comment 6 Avik Sengupta 2003-09-23 15:48:31 UTC
Check - bug still exists after recent changes for ExtSST by Jason ... boo hoo :(
Comment 7 Avik Sengupta 2003-09-23 15:55:50 UTC
See also bug 22742. Similar case, different workbook.
Comment 8 Jason Height 2003-10-14 05:59:54 UTC

*** This bug has been marked as a duplicate of 22742 ***