Bug 15840

Summary: MessageTag causes NullPointer Exception
Product: Taglibs Reporter: Frank Dutenh <frank.dutenhoefer>
Component: I18N TaglibAssignee: Tomcat Developers Mailing List <dev>
Status: CLOSED FIXED    
Severity: blocker CC: xschinnerlx
Priority: P1    
Version: unspecified   
Target Milestone: ---   
Hardware: All   
OS: All   
URL: http://.../i18n-examples/bundle_standard.jsp
Attachments: This is the fixed MessageTag source code

Description Frank Dutenh 2003-01-07 15:20:47 UTC
MessageTag.java uses _bundle (line 268), that causes an NullPointer Exception.
Even the standard example (i18n-examples/bundle_standard.jsp) is not working well.

SOLUTION:
user this.getBundle() instead and the NullPointer bug is solved, please include
in next nightly build, thanks.
Comment 1 Frank Dutenh 2003-01-08 15:01:36 UTC
Created attachment 4372 [details]
This is the fixed MessageTag source code
Comment 2 Frank Dutenh 2003-01-08 15:06:36 UTC
I used the nightly build from 7. January 2003
(jakarta-taglibs-i18n-20030107.zip), and fixed it (see attached MessageTag.java)
Comment 3 Glenn Nielsen 2003-01-11 14:40:27 UTC
Thanks for the bug report, the bug fix should be in the next nightly build.
Comment 4 Glenn Nielsen 2003-01-11 14:44:41 UTC
*** Bug 15989 has been marked as a duplicate of this bug. ***