Bug 16069

Summary: <c:out> does not handle defaults properly
Product: Taglibs Reporter: Dave Cherkassky <dcherk>
Component: Standard TaglibAssignee: Tomcat Developers Mailing List <dev>
Status: RESOLVED FIXED    
Severity: major CC: nathob
Priority: P3    
Version: unspecified   
Target Milestone: ---   
Hardware: PC   
OS: All   
Attachments: Illustrates the default behavior of the <c:out> tag

Description Dave Cherkassky 2003-01-14 16:51:17 UTC
According to spec, the body of the <c:out> tag specifies the default, in case 
the value attribute is empty.  The current implementation however, has a 
problem.

Once a default value is output once, it is also displayed for all subsequent 
uses of the <c:out> tag.

I am using Tomcat 4.1.12 and Standard tag library 1.0.2 in a Win2K environment.

I am attaching a file that reproduces the problem on my system.

Thanks,
 Dave Cherkassky
  V.P. of Software Development
  Djinn Software Inc.
  http://www.djinnsoft.com
  YIM: dcherk71
Comment 1 Dave Cherkassky 2003-01-14 16:52:34 UTC
Created attachment 4418 [details]
Illustrates the default behavior of the <c:out> tag
Comment 2 Shawn Bayern 2003-01-14 20:36:32 UTC
Good catch!  I violated my own guidelines concerning tag-handler reuse.  :-)

It should be fixed now in the CVS head; please let me know if you continue to 
experience any problems.
Comment 3 Pierre Delisle 2003-02-06 18:36:57 UTC
*** Bug 12989 has been marked as a duplicate of this bug. ***