Bug 18117

Summary: Cannot Load WorkBook from non-FileInputStream
Product: POI Reporter: Tony Chao <sys>
Component: POIFSAssignee: POI Developers List <dev>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: P3    
Version: 2.0-dev   
Target Milestone: ---   
Hardware: PC   
OS: Windows XP   

Description Tony Chao 2003-03-18 18:00:38 UTC
RawDataBlock expects to read 512 bytes on every read.
InputStreams that are not FileInputStream can often return less than 512 bytes
on any given read. (e.g. ServletInputStream or ByteArrayInputStream)
Comment 1 Avik Sengupta 2003-03-18 18:33:37 UTC
Try the workaround in bug 13478. Or try wrapping your stream in a buffered input
stream. I think that should help. does it?

*** This bug has been marked as a duplicate of 13478 ***