Bug 19304

Summary: MODLDAP_SHMEM_CACHE location
Product: Apache httpd-2 Reporter: Bradley Schwoerer <schwoerb>
Component: mod_ldapAssignee: Apache HTTPD Bugs Mailing List <bugs>
Status: CLOSED FIXED    
Severity: minor CC: jessh, pr3fab
Priority: P3 Keywords: PatchAvailable
Version: 2.0.45   
Target Milestone: ---   
Hardware: PC   
OS: All   
Attachments: mod_ldap shared mem location patch

Description Bradley Schwoerer 2003-04-25 03:32:48 UTC
Just as an FYI.  Could it be stated for windows (or all OSs) in the 
documentation that the /tmp folder needs to be created on the drive that apache 
is installed on.  This is an issue because by default windows does not have a 
tmp folder in the root of the drive.  Another solution would be to make a 
config option for the location.  If someone would like I could take a stab at 
coding that option.
Comment 1 Jess Holle 2003-06-03 11:28:46 UTC
Another option would be to put this under the logs sub-directory like many 
other Apache MM-like usages do.
Comment 2 Jess Holle 2003-06-03 11:29:06 UTC
This appears to be a duplicate of 20242.
Comment 3 Thom May 2003-06-03 11:34:12 UTC
*** Bug 20242 has been marked as a duplicate of this bug. ***
Comment 4 Thom May 2003-06-03 11:36:01 UTC
No, we're trying to deprecate the usage of the logs dir for anything but
logging. It should use the localstatedir, it being, after all, local state.
Comment 5 Jess Holle 2003-06-03 17:02:08 UTC
Where is localstatedir and is it in fact guaranteed to exist (like the logs dir 

[For now I've patched my Apache 2.0.46 to put this in logs, until a better home 
which is guaranteed to exist "out-of-the-box" (without additional 
configuration) can be found for it.]
Comment 6 Jess Holle 2003-06-05 17:07:49 UTC

Whatever localstatedir is supposed to be, using a hard-coded absolute path is a 
non-starter.  Why?  Though it is certainly not recommended, there are times 
where one must run 2 Apache's on one system (and even on one drive on Windows).

Thus the path use should be configurable or relative to the Apache installation 
directory.  The latter is easy and relatively foolproof.  If 'logs' is 
verboten, then how about introducing a standard 'tmp' directory in the Apache 
layout (complete with proper permission assignment in the binary installer, 
etc) and using it?

Until that's done, I'll stick with using logs...
Comment 7 Markus Herzog 2003-06-25 11:43:29 UTC
Created attachment 6969 [details]
mod_ldap shared mem location patch
Comment 8 Markus Herzog 2003-06-25 11:45:21 UTC
this patch add a new directice LDAPSharedMemCache. with it you can specify the
location of the shared mem cache within your httpd.conf
Comment 9 Jeff Trawick 2003-11-21 22:18:12 UTC
enabling the PatchAvailable keyword
updated doc on submitting patches is at http://httpd.apache.org/dev/patches.html
Comment 10 Graham Leggett 2004-05-21 02:08:47 UTC
Does the LDAPSharedCacheFile directive solve this problem?
Comment 11 Bradley Schwoerer 2004-05-21 03:23:48 UTC
Yes the directive fixes the problem