Bug 20052

Summary: Bug with addCell and getCell
Product: POI Reporter: Micka <msebire>
Component: HSSFAssignee: POI Developers List <dev>
Status: RESOLVED INVALID    
Severity: normal    
Priority: P3    
Version: 2.0-dev   
Target Milestone: ---   
Hardware: PC   
OS: other   

Description Micka 2003-05-20 09:40:38 UTC
Hello,
I have a problem with the function getCell and addCell. When my first column 
which is indexes is the column 3 and the last is the column 5 for example, I 
try to retrieve their values. I use the function getCell(0) to retrieve the 
value of the column 3 to retrieve the value of the column 4. The problem is 
that this function retrieve a null value.

I have tried to do my own modification but I don't know if it's correct...

In the function addCell, I have replace 
    cells.put(new Integer(cell.getCellNum()), cell);
by
    cells.put(new Integer(cells.size()), cell);
with this patch the getCell function runs correctly.
Comment 1 Andy Oliver 2003-07-24 16:36:45 UTC
This looks like a question for the list.