Bug 23167

Summary: --enable-layout never goes to apr apr-util
Product: Apache httpd-2 Reporter: Jim Gifford <giffordj>
Component: BuildAssignee: Apache HTTPD Bugs Mailing List <bugs>
Status: RESOLVED LATER    
Severity: critical CC: poirier, rici
Priority: P3 Keywords: MassUpdate
Version: 2.0.47   
Target Milestone: ---   
Hardware: Other   
OS: Linux   
Attachments: Apr config.log
Config.log for apr-util
custom config.layout
config.log resulting from custom config.layout

Description Jim Gifford 2003-09-14 23:18:24 UTC
At first I thought it was an issue with the config.layout files I created. But 
after hours of playing around I have finally figured it out.

I had created my own layout files with the name LFS. So I added --enable-
layout=LFS to the configure script. When I got to a certain point it would 
drop out and give me an error.

configuring package in srclib/apr now
Configuring APR library
Platform: i686-pc-linux-gnu
APR Version: 0.9.4
** Error: unable to find layout apr
configure failed for srclib/apr

So I then checked the srclib/apr/config.log, that --enable-layout was missing.
So I then changed the config.layout file from LFS to apr. Then it worked util 
it come to apr-util.

APR-util Version: 0.9.4
** Error: unable to find layout apr-util
configure failed for srclib/apr-util

So I then checked the srclib/apr-util/config.log, that --enable-layout was 
missing. So I then changed the config.layout file from LFS to apr-util. 

And then everything built ok.

System Specs : Linux 2.4.22 Autoconf 2.57 Automake 1.77 Make 3.80 GCC 3.31
LFS 4.1 System
Comment 1 Jim Gifford 2003-09-14 23:19:30 UTC
Created attachment 8220 [details]
Apr config.log
Comment 2 Jim Gifford 2003-09-14 23:19:50 UTC
Created attachment 8221 [details]
Config.log for apr-util
Comment 3 Joe Orton 2005-02-28 09:55:15 UTC
Is this still reproducible with 2.0.53?  Can you include your custom
config.layout segment?
Comment 4 Nick Kew 2006-08-08 20:30:29 UTC
No activity after a very long time in NEEDINFO; assuming expired.
Comment 5 Andy Walker 2009-02-17 17:42:15 UTC
I am also experiencing this bug.  My configure command is:

`./configure --enable-layout=sf --enable-modules="deflate headers mime_magic rewrite ssl so" --disable-actions --disable-autoindex --disable-imap --disable-include --disable-negotiation --disable-setenvif --disable-status
--disable-userdir`

I have attached my config.layout and my config.log
Comment 6 Andy Walker 2009-02-17 17:42:57 UTC
Created attachment 23274 [details]
custom config.layout
Comment 7 Andy Walker 2009-02-17 17:43:21 UTC
Created attachment 23275 [details]
config.log resulting from custom config.layout
Comment 8 Andy Walker 2009-02-17 17:48:08 UTC
It's slightly different however in that APR reports that bindir is NONE/bin, even though I set it properly.  
Comment 9 Dan Poirier 2009-03-20 07:38:42 UTC
Can you double-check your config.layout?  I tried it and ran into problems like bindir is set to $/usr/bin, and there are references to ${sfprefix} but sfprefix is never set anywhere.
Comment 10 William A. Rowe Jr. 2018-11-07 21:08:55 UTC
Please help us to refine our list of open and current defects; this is a mass update of old and inactive Bugzilla reports which reflect user error, already resolved defects, and still-existing defects in httpd.

As repeatedly announced, the Apache HTTP Server Project has discontinued all development and patch review of the 2.2.x series of releases. The final release 2.2.34 was published in July 2017, and no further evaluation of bug reports or security risks will be considered or published for 2.2.x releases. All reports older than 2.4.x have been updated to status RESOLVED/LATER; no further action is expected unless the report still applies to a current version of httpd.

If your report represented a question or confusion about how to use an httpd feature, an unexpected server behavior, problems building or installing httpd, or working with an external component (a third party module, browser etc.) we ask you to start by bringing your question to the User Support and Discussion mailing list, see [https://httpd.apache.org/lists.html#http-users] for details. Include a link to this Bugzilla report for completeness with your question.

If your report was clearly a defect in httpd or a feature request, we ask that you retest using a modern httpd release (2.4.33 or later) released in the past year. If it can be reproduced, please reopen this bug and change the Version field above to the httpd version you have reconfirmed with.

Your help in identifying defects or enhancements still applicable to the current httpd server software release is greatly appreciated.