Bug 23363

Summary: JNDI Taglib does not close context when using <jndi:useDirContext> tag
Product: Taglibs Reporter: Mitch Winkle <mitchwinkle>
Component: JNDI TaglibAssignee: Tomcat Developers Mailing List <dev>
Status: RESOLVED LATER    
Severity: major    
Priority: P3    
Version: 1.0   
Target Milestone: ---   
Hardware: PC   
OS: Linux   

Description Mitch Winkle 2003-09-23 19:33:07 UTC
This is important for freeing network resources on heavily laden web-app servers
as well as the LDAP servers they point at.

I had to add <% contextName.close(); %> to the end of my jsp page in order to do
a timely close of the connection to an LDAP resource.

In my Java code that uses JNDI and LDAP, I just use contextName.close() in the
finally clause so as not to forget :-)
Comment 1 Mitch Winkle 2003-09-25 16:56:08 UTC
Additionally, if this is to remain flexible, perhaps for JNDI connection
pooling, then why not just offer a :

<jndi:closeContext id="contextName" /> tag similar to what is used in Taglibs
dbtags with <sql:closeConnection conn="connname"/> ?
Comment 2 Mitch Winkle 2003-09-25 16:58:30 UTC
*** Bug 23364 has been marked as a duplicate of this bug. ***
Comment 3 Henri Yandell 2009-11-29 19:34:53 UTC
Resolving as the JNDI taglib has been retired.