Bug 24715

Summary: Remote SMTP server fix
Product: Taglibs Reporter: Daniel Abayev <dabayev>
Component: Mailer TaglibAssignee: Tomcat Developers Mailing List <dev>
Status: RESOLVED LATER    
Severity: major CC: markus, martinc
Priority: P3 Keywords: PatchAvailable
Version: 1.1   
Target Milestone: ---   
Hardware: PC   
OS: Linux   
URL: http://nagoya.apache.org/eyebrowse/ReadMsg?listName=taglibs-dev@jakarta.apache.org&msgNo=6399
Attachments: A taglibs-mailer.jar with the correct MailTag.class
Patch to resolve this issue.

Description Daniel Abayev 2003-11-14 17:40:05 UTC
Session.getDefaultInstance(props, new MailAuthenticator(user, password));

This code overrides the Properties Class and sets the mail SMPT server back to 
localhost. If localhost is not running SMTP server then the email is not sent 
and an error is thrown.

Use this instead

sessionobj = Session.getInstance(props, new MailAuthenticator(user, password));

on all such occurencies.
Comment 1 Daniel Abayev 2003-11-14 17:42:49 UTC
Created attachment 9112 [details]
A taglibs-mailer.jar with the correct MailTag.class
Comment 2 Martin Cooper 2003-12-09 06:45:57 UTC
Created attachment 9458 [details]
Patch to resolve this issue.
Comment 3 Martin Cooper 2003-12-09 06:50:13 UTC
*** Bug 24321 has been marked as a duplicate of this bug. ***
Comment 4 Martin Cooper 2004-01-29 06:29:25 UTC
Fixed in the 20040129 nightly build.
Comment 5 Martin Cooper 2004-01-30 03:56:12 UTC
Unfixed in the 20040130 nightly build.

The change was vetoed by Glenn Nielsen, since getDefaultInstance() was used 
intentionally in order that the tag could be used in a virtual hosted 
environment. We need a solution that can satisfy both sets of conditions, so 
I'm reopening this bug report in the meantime.

Glenn's message is here:

http://nagoya.apache.org/eyebrowse/ReadMsg?listName=taglibs-
dev@jakarta.apache.org&msgNo=6399
Comment 7 Henri Yandell 2009-11-29 19:39:39 UTC
Resolving. Taglib has been retired.