Bug 25039

Summary: Richtext - Exception is flow when I access to the excel file using HSSF
Product: POI Reporter: Benny Wong <navbwcc>
Component: HSSFAssignee: POI Developers List <dev>
Status: RESOLVED FIXED    
Severity: major CC: ijackson
Priority: P3    
Version: 1.5.1   
Target Milestone: ---   
Hardware: PC   
OS: Windows XP   

Description Benny Wong 2003-11-27 02:50:27 UTC
Situation:
According to the limition HSSF cannot support rich text cells, after inserting 
the rich text cell and deleting it, the HSSF still throw 
exception "NegativeArraySizeException".

Procedure:
1. Using HSSF to access a Excel file and get the data successfully
2. Add two font types in the one cell of Excel file to let the HSSF to throw 
the exception
3. Delete the rich text cell
4. Using HSSF to access the Excel file again

Result:
HSSF still throw the exception "NegativeArraySizeException"
Also, the exception "NegativeArraySizeException" is not suitable to 
description this problem.
Comment 1 Jason Height 2005-08-22 05:25:23 UTC
HEAD now has rich text support.

Jason
Comment 2 Jason Height 2006-07-28 03:23:25 UTC
*** Bug 32286 has been marked as a duplicate of this bug. ***