Bug 25638

Summary: Xml filter example doesn't work
Product: Taglibs Reporter: Felipe Leme <nagoya>
Component: Standard TaglibAssignee: Tomcat Developers Mailing List <dev>
Status: RESOLVED FIXED    
Severity: minor    
Priority: P3    
Version: 1.1   
Target Milestone: ---   
Hardware: PC   
OS: Linux   
URL: http://homer:8080/standard-examples-1.1/xml/Filter.jsp

Description Felipe Leme 2003-12-19 00:59:40 UTC
Output from a Tomcat 5.0.19 container:

type Exception report

message

description The server encountered an internal error () that prevented it from
fulfilling this request.

exception

org.apache.jasper.JasperException: /xml/Filter.jsp(11,0) Unable to load tag
handler class "org.apache.taglibs.standard.extra.spath.SPathTag" for tag "ex:SPath"
	org.apache.jasper.compiler.DefaultErrorHandler.jspError(DefaultErrorHandler.java:83)
	org.apache.jasper.compiler.ErrorDispatcher.dispatch(ErrorDispatcher.java:402)
	org.apache.jasper.compiler.ErrorDispatcher.jspError(ErrorDispatcher.java:236)
	org.apache.jasper.compiler.Parser.parseCustomTag(Parser.java:1356)
	org.apache.jasper.compiler.Parser.parseElements(Parser.java:1598)
	org.apache.jasper.compiler.Parser.parse(Parser.java:171)
	org.apache.jasper.compiler.ParserController.parse(ParserController.java:247)
	org.apache.jasper.compiler.ParserController.parse(ParserController.java:149)
	org.apache.jasper.compiler.ParserController.parse(ParserController.java:135)
	org.apache.jasper.compiler.Compiler.generateJava(Compiler.java:237)
	org.apache.jasper.compiler.Compiler.compile(Compiler.java:456)
	org.apache.jasper.compiler.Compiler.compile(Compiler.java:439)
	org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:552)
	org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:291)
	org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:301)
	org.apache.jasper.servlet.JspServlet.service(JspServlet.java:248)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:856)

note The full stack trace of the root cause is available in the Tomcat logs.
Comment 1 Pierre Delisle 2004-01-20 20:17:28 UTC
Reinstated the extra/spath directory which contains
some very fine code from Shawn. This code is used
by the XML Filter example.

SPath is an example of a parse filter (XMLFilter) for DOMs.  
Its goal is to support the XML Filter example and to help developers
understand what we intended by our 'filter' support.

[Had been removed by error because I thought this was a vestige
of our early attempts at experimenting with various
expression languages]