Bug 26894

Summary: Formula string length limitation (unsigned error)
Product: POI Reporter: Ka Fai Yu <yukafai>
Component: HSSFAssignee: POI Developers List <dev>
Status: RESOLVED DUPLICATE    
Severity: minor    
Priority: P3    
Version: 2.0-pre3   
Target Milestone: ---   
Hardware: All   
OS: All   

Description Ka Fai Yu 2004-02-12 16:09:11 UTC
The hssf.record.formula.StringPtg class seems to have errors dealing with 
formulas with expression parts longer than 127 characters.  The source 
comments suggests that it should handle strings upto 255 characters.  And, I 
got error reading a valid Excel spreadsheet with such formulas.  I believe the 
solution might lie in handling the string length as a short after reading it 
from the first byte of the data in StringPtg.
Comment 1 Avik Sengupta 2005-05-20 12:11:35 UTC

*** This bug has been marked as a duplicate of 26100 ***