Bug 29942

Summary: Importing Excel files that have been created by Open Office on Linux
Product: POI Reporter: Ward <ward.morris>
Component: HSSFAssignee: POI Developers List <dev>
Status: RESOLVED FIXED    
Severity: normal    
Priority: P3    
Version: unspecified   
Target Milestone: ---   
Hardware: PC   
OS: other   
Attachments: Excel file in which workbook won't load.
Same info, but this one works

Description Ward 2004-07-06 20:22:55 UTC
I have worked with HSSF quite a bit and have many functionalities that work; 
however, I have run into a problem reading in the workbook when the file was 
created using Open Office on a Linux machine.  I couldn't find any issues that 
dealt with Excel files that weren't generated using Microsoft Office, but I 
have a good feeling you can't open a file that was created in Open Office.  I 
can tell you that I copied the information from the file created in Open 
Office, copy and pasted into an Excel sheet created in Microsoft Office and 
that worked fine.  Thanks for your help and/or comments.
Comment 1 Avik Sengupta 2004-07-07 07:12:59 UTC
It usually impossible to debug these errors without having a testcase. Could you
please attach a sheet that exhibits the error you cite? In general, several
sheets created by OO have been succesfully opened with poi. 
Comment 2 Ward 2004-07-07 12:36:11 UTC
Created attachment 12050 [details]
Excel file in which workbook won't load.
Comment 3 Ward 2004-07-07 12:36:44 UTC
Created attachment 12051 [details]
Same info, but this one works
Comment 4 Avik Sengupta 2004-07-08 10:20:39 UTC
Which version of openoffice did you use to create this file? 
Comment 5 Avik Sengupta 2007-01-16 01:37:42 UTC
Works as of 12Jan2007, Testcase added. 
http://issues.apache.org/bugzilla/show_bug.cgi?id=41366