Bug 30837

Summary: apxs2 doesn't parse included configuration files
Product: Apache httpd-2 Reporter: Adam Trachtenberg <adam>
Component: BuildAssignee: Apache HTTPD Bugs Mailing List <bugs>
Status: CLOSED WONTFIX    
Severity: minor    
Priority: P3    
Version: 2.0.49   
Target Milestone: ---   
Hardware: All   
OS: All   

Description Adam Trachtenberg 2004-08-25 00:42:14 UTC
My httpd.conf file is setup to Include a series of other configuration files, 
including one with all my LoadModule lines.

When determining how to generate an AddModule/LoadModule directive, apxs2 does 
not bother to resolve these files, all it does it slurp in the master  
configuration. (See line 538.)

This results in a "At least one LoadModule Directive..." error which 
terminates the install. 

The work around is to include a commented out LoadModule line, but this is 
kludgy and non-intuitive.
Comment 1 André Malo 2004-08-25 08:23:39 UTC
I don't think, that we should reimplement the whole config parser in apxs. It's
just a small helper tool. You can add the line yourself and turn off the
automatic config editing.

Thanks!
Comment 2 Adam Trachtenberg 2004-08-25 15:42:35 UTC
Understood completely. FWIW, I stumbled across this while installing PHP 5 and 
this bug causes PHP to bail out in the middle of "make install".

I wouldn't had said much if I wasn't using the default Apache 2 configuration 
on Suse 9.1, so I figured others would also encounter this problem.
Comment 3 André Malo 2004-09-15 20:19:01 UTC
I think, the best would be to issue a report as SuSE's tracker. The apxs
behaviour is correct, IMO. 

-> closing.