Bug 34829

Summary: IOException in InputBuffer when reading xml from post
Product: Tomcat 5 Reporter: Chris Rauschuber <rauschuber>
Component: Connector:CoyoteAssignee: Tomcat Developers Mailing List <dev>
Status: RESOLVED DUPLICATE    
Severity: major    
Priority: P2    
Version: 5.5.9   
Target Milestone: ---   
Hardware: PC   
OS: Windows XP   
Attachments: Tomcat log

Description Chris Rauschuber 2005-05-10 00:35:48 UTC
When reading xml from a post, the following exception occurred:
java.io.IOException
	at org.apache.catalina.connector.InputBuffer.reset(InputBuffer.java:439)
	at org.apache.catalina.connector.CoyoteReader.reset(CoyoteReader.java:121)
	at org.apache.catalina.connector.CoyoteReader.readLine(CoyoteReader.java:178)

More detailed log information will be attached.
Comment 1 Chris Rauschuber 2005-05-10 00:36:54 UTC
Created attachment 14978 [details]
Tomcat log
Comment 2 Remy Maucherat 2005-05-10 00:46:09 UTC
I recommend you modify your code to not use readLine, which is extremely
inefficient.

Unfortunately, I cannot help you fix or investigate this problem.
Comment 3 Remy Maucherat 2005-05-10 20:27:03 UTC
Without further comments or test case -> duplicate.

*** This bug has been marked as a duplicate of 24897 ***