Bug 34938

Summary: [PATCH] Batik does not build with Java 5 (JDK 1.5) compiler
Product: Batik - Now in Jira Reporter: Jochen Kuhnle <werbung>
Component: (RFE) Request For ExtensionAssignee: Batik Developer's Mailing list <batik-dev>
Status: RESOLVED FIXED    
Severity: normal Keywords: PatchAvailable
Priority: P2    
Version: 1.8   
Target Milestone: ---   
Hardware: Other   
OS: other   
Attachments: Path for the build files
ant-1.6.2.jar for lib/ directory
ant-launcher-1.6.2.jar for lib/ directory

Description Jochen Kuhnle 2005-05-16 17:20:11 UTC
Batik does not compile with JDK 1.5. This patch resolves this with an upgrade to
Ant 1.6.2 and patches to the build files.
Comment 1 Jochen Kuhnle 2005-05-16 17:20:53 UTC
Created attachment 15047 [details]
Path for the build files
Comment 2 Jochen Kuhnle 2005-05-16 17:23:19 UTC
Created attachment 15048 [details]
ant-1.6.2.jar for lib/ directory
Comment 3 Jochen Kuhnle 2005-05-16 17:24:04 UTC
Created attachment 15049 [details]
ant-launcher-1.6.2.jar for lib/ directory
Comment 4 Thomas Deweese 2005-09-25 20:08:34 UTC
Batik 'trunk' should now build under JDK 1.5 (aka Java 5.0).