Bug 35182

Summary: Having Problems with JSP Image Tag Library deployed in Websphere environment in Linux
Product: Taglibs Reporter: das <mannagiri>
Component: Sandbox TaglibsAssignee: Tomcat Developers Mailing List <dev>
Status: RESOLVED WORKSFORME    
Severity: critical    
Priority: P2    
Version: unspecified   
Target Milestone: ---   
Hardware: Other   
OS: Linux   

Description das 2005-06-02 11:24:07 UTC
Hi,

Having problems with JSP Image Tag Library when deployed in Websphere 
environment in a Linux Box
It gives me a HTTP 407 error. The image-examples does not work for the 1st 
method - ie, Saved within the context and accessed as a static image
It is not allowing the creation of dynamic folder (generated).

Please help me

Thanks and Regards
Comment 1 Abey Mullassery 2005-06-04 14:55:20 UTC
Please read the below mentioned postings and confirm that the issue is NOT the
same. If Websphere does NOT allow access to the file system the Image taglib can
only use the temp directory.


Martin Cooper's post about using the temp directory for generated images
http://article.gmane.org/gmane.comp.jakarta.taglibs.devel/3141

"Per the servlet spec, the container is required to provide a temp directory
for each web app."
...
"Attempting to use the file system in general, outside of the abovementioned
temp directory, is not guaranteed to be portable, for the simple reason that
there is no guarantee that there *is* a file system."


AND the implementation notes by me (Abey Mullassery)
http://article.gmane.org/gmane.comp.jakarta.taglibs.devel/3142

"Current implementation uses the local directory (as it was before this 
update) if the "dir" attribute is specified. If not, the ImageTag 
defaults to the use of web app's temp directory and the usage of the 
ImageServlet."
Comment 2 Abey Mullassery 2006-11-07 08:19:23 UTC
Closing since no further info was provided.