Bug 39512

Summary: Can have no more than 60 form controls on a sheet
Product: POI Reporter: Johnathon Harris <john.harris>
Component: HSSFAssignee: POI Developers List <dev>
Status: RESOLVED DUPLICATE    
Severity: major    
Priority: P1    
Version: 2.5-FINAL   
Target Milestone: ---   
Hardware: All   
OS: other   
Attachments: XLS with 60 option buttons, processed correctly by HSSF readwrite.
XLS with 61 option buttons, HSSF readwrite produces file which Excel cannot read correctly.

Description Johnathon Harris 2006-05-08 15:56:48 UTC
Using the HSSF readwrite test I can have no more than 60 form controls on a
worksheet else Excel cannot read the file that is created by POI. Error message
from Excel is: 'Damage to the file was so extensive that repairs were not possible.'

The original spreadsheet is created in Excel. 61 form controls are placed. It
does not seem to matter which form control is used, problem reproducible using
option buttons, checkboxes and normal buttons.

Example spreadsheet files to follow. This problem can be reproduced just by
running the HSSF readwrite test.
java -cp poi.jar org.apache.poi.hssf.dev.HSSF 61buttons.xls out61.xls

This problem occurs using 2.5 and 3.0a releases at least.

Thanks for your work on POI.
Comment 1 Johnathon Harris 2006-05-08 15:58:25 UTC
Created attachment 18245 [details]
XLS with 60 option buttons, processed correctly by HSSF readwrite.
Comment 2 Johnathon Harris 2006-05-08 15:59:10 UTC
Created attachment 18246 [details]
XLS with 61 option buttons, HSSF readwrite produces file which Excel cannot read correctly.
Comment 3 Yegor Kozlov 2007-11-23 04:57:03 UTC
Fixed.

See Bug 43877 for details.

Regards,
Yegor

*** This bug has been marked as a duplicate of 43877 ***